Mercurial > hg > portage
comparison www-apps/mantisbt/mantisbt-1.2.12.ebuild @ 341:038e60afdaeb
ebuild for mantisbt 1.2.12
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 05 Dec 2012 05:39:44 +0000 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
340:9c4b58c14668 | 341:038e60afdaeb |
---|---|
1 # Copyright 1999-2011 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/www-apps/mantisbt/mantisbt-1.2.8.ebuild,v 1.3 2011/12/14 22:53:05 mabi Exp $ | |
4 | |
5 EAPI="2" | |
6 | |
7 inherit eutils webapp depend.php | |
8 | |
9 DESCRIPTION="PHP/MySQL/Web based bugtracking system" | |
10 HOMEPAGE="http://www.mantisbt.org/" | |
11 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz" | |
12 | |
13 LICENSE="GPL-2" | |
14 KEYWORDS="~amd64 ~x86" | |
15 IUSE="" | |
16 | |
17 RDEPEND=" | |
18 virtual/httpd-php | |
19 virtual/httpd-cgi | |
20 || ( <dev-lang/php-5.3[pcre] >=dev-lang/php-5.3 ) | |
21 >=dev-php/ezc-Base-1.8 | |
22 >=dev-php/ezc-Graph-1.5 | |
23 >=dev-php/adodb-5.10" | |
24 | |
25 src_prepare() { | |
26 # Drop external libraries | |
27 rm -r "${S}/library/adodb/" | |
28 rm -r "${S}/library/ezc/"{Base,Graph} | |
29 sed -e 's:ezc/Base/src/base.php:ezc/Base/base.php:' \ | |
30 -i "${S}"/plugins/MantisGraph/{core/graph_api.php,pages/summary_graph_cumulative_bydate2.php} \ | |
31 || die | |
32 # Fix incorrect filename | |
33 sed -e 's:config_default_inc.php:config_defaults_inc.php:' \ | |
34 -i "${S}/lang/strings_russian.txt" || die | |
35 } | |
36 | |
37 src_install() { | |
38 webapp_src_preinst | |
39 rm doc/{LICENSE,INSTALL} | |
40 dodoc doc/{CREDITS,CUSTOMIZATION,RELEASE} doc/en/* | |
41 | |
42 rm -rf doc packages | |
43 mv config_inc.php.sample config_inc.php | |
44 cp -R . "${D}/${MY_HTDOCSDIR}" | |
45 | |
46 webapp_configfile "${MY_HTDOCSDIR}/config_inc.php" | |
47 webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.0.0.txt" | |
48 webapp_src_install | |
49 } |