Mercurial > hg > portage
comparison dev-util/visualvm-bin/visualvm-bin-2.0.2.ebuild @ 519:060bd9c14587
new visualvm version
author | Dirk Olmes <dirk.olmes@codedo.de> |
---|---|
date | Wed, 20 May 2020 09:39:56 +0200 |
parents | dev-util/visualvm-bin/visualvm-bin-2.0.1.ebuild@88c03660056d |
children |
comparison
equal
deleted
inserted
replaced
518:a2917913537b | 519:060bd9c14587 |
---|---|
1 # Copyright 1999-2018 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI=7 | |
5 | |
6 DESCRIPTION="Integrates commandline JDK tools and profiling capabilities" | |
7 HOMEPAGE="https://visualvm.github.io" | |
8 | |
9 MY_PV="${PV//\./}" | |
10 SRC_URI="https://github.com/visualvm/visualvm.src/releases/download/${PV}/visualvm_${MY_PV}.zip" | |
11 S="${WORKDIR}/visualvm_${MY_PV}" | |
12 | |
13 SLOT="0" | |
14 KEYWORDS="amd64" | |
15 | |
16 src_prepare() { | |
17 default | |
18 | |
19 # Remove unneeded binaries | |
20 rm bin/*.exe | |
21 rm -rv platform/lib/*.{dll,exe} \ | |
22 platform/modules/lib/{amd64/*.dll,i386,x86} || die | |
23 } | |
24 | |
25 src_install() { | |
26 local DEST_DIR="/opt/${PN}-${PV}" | |
27 | |
28 exeinto ${DEST_DIR}/bin | |
29 doexe bin/visualvm | |
30 | |
31 insinto ${DEST_DIR} | |
32 doins -r etc platform visualvm | |
33 } |