Mercurial > hg > portage
comparison net-im/psi-plus/psi-plus-0.16.545.535.ebuild @ 410:06486d4a9de7
update psi to the latest available snapshot
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 20 Apr 2016 06:22:34 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
408:757d9b59e20b | 410:06486d4a9de7 |
---|---|
1 | |
2 EAPI=5 | |
3 | |
4 inherit eutils l10n multilib gnome2-utils qt4-r2 | |
5 | |
6 DESCRIPTION="Qt4 Jabber client, with Licq-like interface" | |
7 HOMEPAGE="https://github.com/psi-plus/psi-plus-snapshots/" | |
8 SRC_URI="https://github.com/psi-plus/psi-plus-snapshots/archive/${PV}.tar.gz" | |
9 | |
10 S="${WORKDIR}/psi-plus-snapshots-${PV}" | |
11 | |
12 LICENSE="GPL-2" | |
13 SLOT="0" | |
14 KEYWORDS="~amd64 ~x86" | |
15 IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin plugins spell ssl xscreensaver watcherplugin whiteboarding" | |
16 #RESTRICT="test" | |
17 | |
18 RDEPEND="app-arch/unzip | |
19 >=dev-qt/qtgui-4.7:4 | |
20 >=app-crypt/qca-2.0.2:2[qt4(+)] | |
21 x11-libs/libX11 | |
22 dbus? ( >=dev-qt/qtdbus-4.7:4 ) | |
23 spell? ( >=app-text/enchant-1.3.0 ) | |
24 xscreensaver? ( x11-libs/libXScrnSaver ) | |
25 whiteboarding? ( dev-qt/qtsvg:4 ) | |
26 || ( >=sys-libs/zlib-1.2.5.1-r2[minizip] <sys-libs/zlib-1.2.5.1-r1 )" | |
27 | |
28 DEPEND="${RDEPEND} | |
29 sys-devel/qconf | |
30 doc? ( app-doc/doxygen )" | |
31 | |
32 PDEPEND="crypt? ( app-crypt/qca:2[gpg] ) | |
33 jingle? ( net-im/psimedia | |
34 app-crypt/qca:2[openssl] ) | |
35 ssl? ( app-crypt/qca:2[openssl] ) | |
36 otrplugin? ( net-libs/libotr app-text/htmltidy )" | |
37 | |
38 src_prepare() { | |
39 epatch_user | |
40 } | |
41 | |
42 src_configure() { | |
43 # unable to use econf because of non-standard configure script | |
44 local confcmd="./configure | |
45 --prefix=/usr | |
46 --datadir=/usr/share | |
47 --libdir=/usr/lib64 | |
48 --disable-growl | |
49 --with-qca-inc=/usr/include/qca2 | |
50 --with-qca-lib=/usr/lib64/qca2 | |
51 $(use dbus || echo '--disable-qdbus') | |
52 $(use debug && echo '--debug') | |
53 $(use plugins && echo '--enable-plugins') | |
54 $(use spell || echo '--disable-aspell') | |
55 $(use spell || echo '--disable-enchant') | |
56 $(use xscreensaver || echo '--disable-xss') | |
57 $(use whiteboarding && echo '--enable-whiteboarding')" | |
58 | |
59 echo ${confcmd} | |
60 ${confcmd} || die "configure failed" | |
61 ## Makefile is not always created... | |
62 #[[ ! -f Makefile ]] && die "configure failed" | |
63 } | |
64 | |
65 src_compile() { | |
66 emake || die "emake failed" | |
67 | |
68 if use autoreplyplugin; then | |
69 cd src/plugins/generic/autoreplyplugin | |
70 qmake | |
71 make | |
72 cd ../../../.. | |
73 fi | |
74 | |
75 if use otrplugin; then | |
76 cd src/plugins/generic/otrplugin | |
77 qmake | |
78 make | |
79 cd ../../../.. | |
80 fi | |
81 | |
82 if use watcherplugin; then | |
83 cd src/plugins/generic/watcherplugin | |
84 qmake | |
85 make | |
86 cd ../../../.. | |
87 fi | |
88 } | |
89 | |
90 src_install() { | |
91 emake DESTDIR="${D}" INSTALL_ROOT="${D}" install | |
92 dodoc README TODO ChangeLog | |
93 | |
94 if use autoreplyplugin; then | |
95 cd src/plugins/generic/autoreplyplugin | |
96 | |
97 local plugindir="/usr/$(get_libdir)/psi-plus/plugins" | |
98 dodir "${plugindir}" | |
99 insinto "${plugindir}" | |
100 doins libautoreplyplugin.so | |
101 | |
102 cd ../../../.. | |
103 fi | |
104 | |
105 if use otrplugin; then | |
106 cd src/plugins/generic/otrplugin | |
107 | |
108 local plugindir="/usr/$(get_libdir)/psi-plus/plugins" | |
109 dodir "${plugindir}" | |
110 insinto "${plugindir}" | |
111 doins libotrplugin.so | |
112 | |
113 cd ../../../.. | |
114 fi | |
115 | |
116 if use watcherplugin; then | |
117 cd src/plugins/generic/watcherplugin | |
118 | |
119 local plugindir="/usr/$(get_libdir)/psi-plus/plugins" | |
120 dodir "${plugindir}" | |
121 insinto "${plugindir}" | |
122 doins libwatcherplugin.so | |
123 | |
124 cd ../../../.. | |
125 fi | |
126 } | |
127 | |
128 pkg_preinst() { | |
129 gnome2_icon_savelist | |
130 } | |
131 | |
132 pkg_postinst() { | |
133 gnome2_icon_cache_update | |
134 } | |
135 | |
136 pkg_postrm() { | |
137 gnome2_icon_cache_update | |
138 } |