comparison dev-db/pgadmin3/pgadmin3-1.6.3.ebuild @ 25:126096e3d51b

added ebuilds from the svn portage tree
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 26 May 2008 16:41:22 +0200
parents
children
comparison
equal deleted inserted replaced
24:41713688d1e0 25:126096e3d51b
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 #
4
5 inherit wxwidgets eutils autotools
6
7 KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
8
9 DESCRIPTION="wxWidgets GUI for PostgreSQL."
10 HOMEPAGE="http://www.pgadmin.org/"
11 SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
12 LICENSE="Artistic"
13 SLOT="0"
14 IUSE="debug"
15
16 DEPEND="=x11-libs/wxGTK-2.8*
17 >=dev-db/libpq-7.4
18 >=dev-libs/libxml2-2.5
19 >=dev-libs/libxslt-1.1"
20 RDEPEND="${DEPEND}"
21
22 pkg_setup() {
23 export WX_GTK_VER=2.8
24 export WX_HOME=/usr
25 need-wxwidgets unicode
26 }
27
28 src_unpack() {
29 unpack ${A}
30 cd "${S}"
31
32 # --debug=yes/no for wx_config is only needed if wxGTK debug and
33 # release versions are installed aside. Which is not possible
34 # on Gentoo at the moment.
35 sed -i \
36 -e 's/--debug=[yesno]* //g' \
37 acinclude.m4 || die "sed failed"
38 eautoreconf
39 }
40
41 src_compile() {
42 cd "${S}"
43 patch -p0 < ${FILESDIR}/patch.p0
44 # pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it
45 econf \
46 --with-wx-config=/${WX_CONFIG/\ /usr} \
47 --with-wx-version=2.8 \
48 || die "econf failed"
49 emake || die "emake failed"
50 }
51
52 src_install() {
53 cd "${S}"
54
55 einstall || die "einstall failed"
56
57 insinto /usr/share/pixmaps
58 newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
59
60 insinto /usr/share/pgadmin3
61 newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm
62
63 insinto /usr/share/applications
64 doins "${S}/pkg/pgadmin3.desktop"
65 }