Mercurial > hg > portage
comparison dev-db/pgadmin3/pgadmin3-1.8.2.ebuild @ 25:126096e3d51b
added ebuilds from the svn portage tree
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Mon, 26 May 2008 16:41:22 +0200 |
parents | |
children | 31f34c64d33d |
comparison
equal
deleted
inserted
replaced
24:41713688d1e0 | 25:126096e3d51b |
---|---|
1 # Copyright 1999-2006 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # | |
4 | |
5 inherit wxwidgets eutils autotools | |
6 | |
7 KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86" | |
8 | |
9 DESCRIPTION="wxWidgets GUI for PostgreSQL." | |
10 HOMEPAGE="http://www.pgadmin.org/" | |
11 SRC_URI="mirror://postgresql/pgadmin3/release/v${PV/_/-}/src/${P/_/-}.tar.gz" | |
12 LICENSE="Artistic" | |
13 SLOT="0" | |
14 IUSE="debug" | |
15 S="${WORKDIR}/${P/_/-}" | |
16 | |
17 DEPEND="=x11-libs/wxGTK-2.8* | |
18 >=dev-db/libpq-8 | |
19 >=dev-libs/libxml2-2.6.18 | |
20 >=dev-libs/libxslt-1.1" | |
21 RDEPEND="${DEPEND}" | |
22 | |
23 pkg_setup() { | |
24 export WX_GTK_VER=2.8 | |
25 export WX_HOME=/usr | |
26 need-wxwidgets unicode | |
27 } | |
28 | |
29 src_unpack() { | |
30 unpack ${A} | |
31 cd "${S}" | |
32 | |
33 # --debug=yes/no for wx_config is only needed if wxGTK debug and | |
34 # release versions are installed aside. Which is not possible | |
35 # on Gentoo at the moment. | |
36 sed -i \ | |
37 -e 's/--debug=[yesno]* //g' \ | |
38 acinclude.m4 || die "sed failed" | |
39 eautoreconf | |
40 } | |
41 | |
42 src_compile() { | |
43 cd "${S}" | |
44 patch -p0 < ${FILESDIR}/patch.p0 | |
45 # pgadmin3 inserts WX_HOME before the WX_CONFIG path below, so we have to strip "/usr" from it | |
46 econf \ | |
47 --with-wx-config=/${WX_CONFIG/\ /usr} \ | |
48 --with-wx-version=2.8 \ | |
49 || die "econf failed" | |
50 emake || die "emake failed" | |
51 } | |
52 | |
53 src_install() { | |
54 cd "${S}" | |
55 | |
56 einstall || die "einstall failed" | |
57 | |
58 insinto /usr/share/pixmaps | |
59 newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm | |
60 | |
61 insinto /usr/share/pgadmin3 | |
62 newins "${S}/src/include/images/elephant48.xpm" pgadmin3.xpm | |
63 | |
64 insinto /usr/share/applications | |
65 doins "${S}/pkg/pgadmin3.desktop" | |
66 } |