Mercurial > hg > portage
comparison dev-python/pygments/pygments-2.1.3.ebuild @ 442:151df3031a78
revive the pygments 2.1.3 ebuild as it's still installed
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 10 May 2017 01:14:04 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
441:e493bd4a6f5e | 442:151df3031a78 |
---|---|
1 # Copyright 1999-2017 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI=6 | |
5 | |
6 PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 ) | |
7 | |
8 inherit distutils-r1 bash-completion-r1 vcs-snapshot | |
9 | |
10 MY_PN="Pygments" | |
11 MY_P="${MY_PN}-${PV}" | |
12 | |
13 DESCRIPTION="Pygments is a syntax highlighting package written in Python" | |
14 HOMEPAGE="http://pygments.org/ https://pypi.python.org/pypi/Pygments" | |
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz" | |
16 | |
17 LICENSE="BSD" | |
18 SLOT="0" | |
19 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris" | |
20 IUSE="doc test" | |
21 | |
22 RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]" | |
23 DEPEND="${RDEPEND} | |
24 doc? ( dev-python/sphinx[${PYTHON_USEDEP}] ) | |
25 test? ( | |
26 dev-python/nose[${PYTHON_USEDEP}] | |
27 virtual/ttf-fonts )" | |
28 # dev-texlive/texlive-latexrecommended | |
29 # Removing / commenting out this dep. I can find no mention of it in tests other than | |
30 # importing pygment's own tex module. If it's there and I missed it just uncomment and re-add | |
31 # Tests pass without it | |
32 | |
33 S="${WORKDIR}/${MY_P}" | |
34 | |
35 python_compile_all() { | |
36 use doc && emake -C doc html | |
37 } | |
38 | |
39 python_test() { | |
40 cp -r -l tests "${BUILD_DIR}"/ || die | |
41 # With pypy3 there is 1 error out of 1556 tests when run as is and | |
42 # (SKIP=8, errors=1, failures=1) when run with 2to3; meh | |
43 nosetests --verbosity=3 -w "${BUILD_DIR}"/tests \ | |
44 || die "Tests fail with ${EPYTHON}" | |
45 } | |
46 | |
47 python_install_all() { | |
48 use doc && local HTML_DOCS=( doc/_build/html/. ) | |
49 | |
50 distutils-r1_python_install_all | |
51 newbashcomp external/pygments.bashcomp pygmentize | |
52 } |