comparison net-p2p/deluge/deluge-1.3.4.ebuild @ 322:15868e686a6f

bump deluge to 1.3.4
author holger
date Tue, 06 Mar 2012 17:52:49 +0100
parents net-p2p/deluge/deluge-1.3.3.ebuild@a6bb3a2f981a
children
comparison
equal deleted inserted replaced
321:b46f198aea61 322:15868e686a6f
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/net-p2p/deluge/deluge-1.3.3.ebuild,v 1.2 2011/08/17 13:52:12 armin76 Exp $
4
5 EAPI="3"
6 PYTHON_DEPEND="2:2.5"
7
8 inherit distutils flag-o-matic
9
10 DESCRIPTION="BitTorrent client with a client/server model."
11 HOMEPAGE="http://deluge-torrent.org/"
12 SRC_URI="http://download.deluge-torrent.org/source/${P}.tar.lzma"
13
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
17 IUSE="gtk libnotify webinterface"
18
19 DEPEND=">=net-libs/rb_libtorrent-0.14.9[python]
20 dev-python/setuptools
21 dev-util/intltool"
22 RDEPEND="${DEPEND}
23 dev-python/chardet
24 dev-python/pyopenssl
25 dev-python/pyxdg
26 || ( dev-lang/python:2.7 dev-lang/python:2.6 dev-python/simplejson )
27 >=dev-python/twisted-8.1
28 >=dev-python/twisted-web-8.1
29 gtk? (
30 dev-python/pygame
31 dev-python/pygobject
32 >=dev-python/pygtk-2.12
33 gnome-base/librsvg
34 libnotify? ( dev-python/notify-python )
35 )
36 webinterface? ( dev-python/mako )"
37
38 pkg_setup() {
39 append-ldflags $(no-as-needed)
40 python_set_active_version 2
41 python_pkg_setup
42 }
43
44 src_prepare() {
45 distutils_src_prepare
46 python_convert_shebangs -r 2 .
47 }
48
49 src_install() {
50 distutils_src_install
51 newinitd "${FILESDIR}"/deluged.init deluged
52 newconfd "${FILESDIR}"/deluged.conf deluged
53 }
54
55 pkg_postinst() {
56 distutils_pkg_postinst
57 elog
58 elog "If after upgrading it doesn't work, please remove the"
59 elog "'~/.config/deluge' directory and try again, but make a backup"
60 elog "first!"
61 elog
62 elog "To start the daemon either run 'deluged' as user"
63 elog "or modify /etc/conf.d/deluged and run"
64 elog "/etc/init.d/deluged start as root"
65 elog "You can still use deluge the old way"
66 elog
67 elog "For more information look at http://dev.deluge-torrent.org/wiki/Faq"
68 elog
69 }