Mercurial > hg > portage
comparison dev-java/jrockit-jdk-bin/jrockit-jdk-bin-1.6.0.01.ebuild @ 217:186f8bced4d5
Automated merge with http://hoho.dyndns.org/hg/portage
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Tue, 27 Apr 2010 14:21:11 +0200 |
parents | f00d13ecb343 |
children |
comparison
equal
deleted
inserted
replaced
216:68c3ea31610e | 217:186f8bced4d5 |
---|---|
1 # Copyright 1999-2007 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header$ | |
4 | |
5 # WARNING: This is the default VM on ia64, so treat this ebuild | |
6 # with proper care. | |
7 | |
8 # The stripping of symbols seems to mess up the BEA code. Not sure why. | |
9 RESTRICT="strip fetch" | |
10 | |
11 inherit java-vm-2 versionator | |
12 | |
13 PV_MAJOR="$(get_version_component_range 1-3 ${PV})" | |
14 PV_EXTRA="$(get_version_component_range 4 ${PV})" | |
15 UPSTREAM_RELEASE="27.3.1" | |
16 | |
17 SRC_URI_BASE="jrockit-R${UPSTREAM_RELEASE}-jdk${PV_MAJOR}_${PV_EXTRA}-linux-" | |
18 #SRC_URI="x86? ( ${SRC_URI_BASE}ia32.bin ) | |
19 # amd64? ( ${SRC_URI_BASE}x64.bin ) | |
20 # ia64? ( ${SRC_URI_BASE}ipf.bin )" | |
21 SRC_URI="x86? ( ${SRC_URI_BASE}ia32.bin )" | |
22 | |
23 DESCRIPTION="BEA WebLogic's J2SE Development Kit, R${UPSTREAM_RELEASE}" | |
24 | |
25 HOMEPAGE="http://commerce.bea.com/products/weblogicjrockit/jrockit_prod_fam.jsp" | |
26 | |
27 LICENSE="jrockit" | |
28 SLOT="1.6" | |
29 KEYWORDS="-* ~amd64 ~ia64 ~x86" | |
30 IUSE="doc examples" | |
31 | |
32 DEPEND="app-arch/unzip" | |
33 RDEPEND="doc? ( =dev-java/java-sdk-docs-1.5.0* )" | |
34 JAVA_PROVIDE="jdbc-stdext jdbc-rowset" | |
35 | |
36 QA_TEXTRELS_amd64="opt/${P}/mercuryprofiler/lib/sparc-sunos/libprobejni.so | |
37 opt/${P}/mercuryprofiler/lib/x86-linux/libprobejni.so" | |
38 | |
39 # not working for some reason... | |
40 # because it probably needs WX_LOAD and not EXECSTACK | |
41 QA_EXECSTACK_amd64="opt/${P}/mercuryprofiler/bin/sparc-sunos/systemmetrics | |
42 opt/${P}/mercuryprofiler/lib/sparc-sunos/libprobejni.so" | |
43 | |
44 QA_TEXTRELS_x86="opt/${P}/jre/lib/i386/jrockit/libjvm.so | |
45 opt/${P}/jre/lib/i386/motif21/libmawt.so | |
46 opt/${P}/jre/lib/i386/libjmapi.so | |
47 opt/${P}/mercuryprofiler/lib/x86-linux/libjvmti.so | |
48 opt/${P}/mercuryprofiler/lib/x86-linux/libprobejni.so | |
49 opt/${P}/mercuryprofiler/lib/sparc-sunos64/libjvmti.so | |
50 opt/${P}/mercuryprofiler/lib/sparc-sunos64/libprobejni.so | |
51 opt/${P}/mercuryprofiler/lib/sparc-sunos/libjvmti.so | |
52 opt/${P}/mercuryprofiler/lib/sparc-sunos/libprobejni.so" | |
53 | |
54 QA_EXECSTACK_x86="opt/${P}/bin/* | |
55 opt/${P}/jre/bin/* | |
56 opt/${P}/jre/lib/i386/jrockit/libjvm.so | |
57 opt/${P}/jre/lib/i386/libnet.so" | |
58 | |
59 QA_WX_LOAD_x86="opt/${P}/mercuryprofiler/bin/sparc-sunos/systemmetrics | |
60 opt/${P}/mercuryprofiler/bin/sparc-sunos/reference_sort | |
61 opt/${P}/mercuryprofiler/lib/sparc-sunos64/libjvmti.so | |
62 opt/${P}/mercuryprofiler/lib/sparc-sunos64/libprobejni.so | |
63 opt/${P}/mercuryprofiler/lib/sparc-sunos/libjvmti.so | |
64 opt/${P}/mercuryprofiler/lib/sparc-sunos/libprobejni.so" | |
65 | |
66 pkg_nofetch() { | |
67 einfo "Please download ${A} from:" | |
68 einfo ${HOMEPAGE} | |
69 einfo "and move it to ${DISTDIR}" | |
70 } | |
71 | |
72 src_unpack() { | |
73 # unpack cannot determine file format | |
74 # unzip to get more zips | |
75 unzip ${DISTDIR}/${A} || die | |
76 | |
77 mkdir ${S} || die | |
78 | |
79 # this is ugly but don't see any better way | |
80 # empty jre dir is part of the zip | |
81 unzip *sdk_no_jre.zip -d ${S} || die | |
82 # remove so it doesn't affect next unzip | |
83 rm *sdk_no_jre.zip || die | |
84 # unpack the jre into its dir | |
85 unzip *jre.zip -d ${S}/jre || die | |
86 } | |
87 | |
88 src_install() { | |
89 local dirs="bin include jre lib missioncontrol src.zip" | |
90 | |
91 insinto "/opt/${P}" | |
92 for i in ${dirs} ; do | |
93 doins -r $i || die | |
94 done | |
95 | |
96 if use examples; then | |
97 doins -r demo || die | |
98 doins -r sample || die | |
99 fi | |
100 | |
101 newdoc README.txt README || die | |
102 dodoc LICENSE || die | |
103 | |
104 chmod +x ${D}/opt/${P}/bin/* ${D}/opt/${P}/jre/bin/* || die "Could not chmod" | |
105 set_java_env | |
106 } | |
107 | |
108 pkg_postinst () { | |
109 # Set as default VM if none exists | |
110 java-vm-2_pkg_postinst | |
111 elog "Please review the license agreement in /usr/share/doc/${PF}/LICENSE" | |
112 elog "If you do not agree to the terms of this license, please uninstall this package" | |
113 } |