Mercurial > hg > portage
comparison app-emulation/docker-compose-bin/docker-compose-bin-1.5.0.ebuild @ 402:1d67465feb67
add a ebuild for docker-compose-bin
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Mon, 09 Nov 2015 19:42:01 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
401:261f734e7c25 | 402:1d67465feb67 |
---|---|
1 # Copyright 1999-2014 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: $ | |
4 | |
5 EAPI=5 | |
6 | |
7 DESCRIPTION="Compose is a tool for defining and running complex applications with Docker" | |
8 HOMEPAGE="https://docs.docker.com/compose/" | |
9 MY_PN="${PN%-bin}" | |
10 MY_PV="${PV/_/}" | |
11 SRC_URI=" | |
12 amd64? ( https://github.com/docker/compose/releases/download/${MY_PV}/${MY_PN}-Linux-x86_64 -> ${P}-Linux-x86_64 ) | |
13 " | |
14 | |
15 LICENSE="Apache-2.0" | |
16 SLOT="0" | |
17 KEYWORDS="~amd64" | |
18 IUSE="" | |
19 | |
20 DEPEND="" | |
21 RDEPEND="${DEPEND}" | |
22 | |
23 RESTRICT="installsources strip" | |
24 | |
25 S="${DISTDIR}" | |
26 | |
27 src_install() { | |
28 newbin ${P}-Linux-x86_64 ${MY_PN} | |
29 } |