Mercurial > hg > portage
comparison net-im/psi-plus/psi-plus-0.16.449.ebuild @ 378:2288352e429d
add a ebuild for psi plus
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Tue, 03 Mar 2015 11:03:08 +0100 |
parents | |
children | 8d5629e582b5 |
comparison
equal
deleted
inserted
replaced
377:368438494ded | 378:2288352e429d |
---|---|
1 | |
2 EAPI=5 | |
3 | |
4 inherit eutils l10n multilib gnome2-utils qt4-r2 | |
5 | |
6 DESCRIPTION="Qt4 Jabber client, with Licq-like interface" | |
7 HOMEPAGE="https://github.com/psi-plus/psi-plus-snapshots/" | |
8 #SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2" | |
9 SRC_URI="https://github.com/psi-plus/psi-plus-snapshots/archive/${PV}.tar.gz" | |
10 | |
11 S="${WORKDIR}/psi-plus-snapshots-${PV}" | |
12 | |
13 LICENSE="GPL-2" | |
14 SLOT="0" | |
15 KEYWORDS="~amd64 ~x86" | |
16 IUSE="crypt dbus debug doc jingle spell ssl xscreensaver whiteboarding" | |
17 #RESTRICT="test" | |
18 | |
19 RDEPEND="app-arch/unzip | |
20 >=dev-qt/qtgui-4.7:4[qt3support] | |
21 >=dev-qt/qt3support-4.7:4 | |
22 >=app-crypt/qca-2.0.2:2[qt4(+)] | |
23 x11-libs/libX11 | |
24 dbus? ( >=dev-qt/qtdbus-4.7:4 ) | |
25 spell? ( >=app-text/enchant-1.3.0 ) | |
26 xscreensaver? ( x11-libs/libXScrnSaver ) | |
27 whiteboarding? ( dev-qt/qtsvg:4 ) | |
28 || ( >=sys-libs/zlib-1.2.5.1-r2[minizip] <sys-libs/zlib-1.2.5.1-r1 )" | |
29 | |
30 DEPEND="${RDEPEND} | |
31 sys-devel/qconf | |
32 doc? ( app-doc/doxygen )" | |
33 | |
34 PDEPEND="crypt? ( app-crypt/qca:2[gpg] ) | |
35 jingle? ( net-im/psimedia | |
36 app-crypt/qca:2[openssl] ) | |
37 ssl? ( app-crypt/qca:2[openssl] )" | |
38 | |
39 #DOC_CONTENTS='Psi+ support(USE="extras") was removed from ebuild since 0.15' | |
40 #FORCE_PRINT_ELOG=1 | |
41 | |
42 src_prepare() { | |
43 epatch_user | |
44 } | |
45 | |
46 src_configure() { | |
47 # unable to use econf because of non-standard configure script | |
48 local confcmd="./configure | |
49 --prefix=/usr | |
50 --datadir=/usr/share | |
51 --libdir=/usr/lib64 | |
52 --disable-growl | |
53 $(use dbus || echo '--disable-qdbus') | |
54 $(use debug && echo '--debug') | |
55 $(use spell || echo '--disable-aspell') | |
56 $(use spell || echo '--disable-enchant') | |
57 $(use xscreensaver || echo '--disable-xss') | |
58 $(use whiteboarding && echo '--enable-whiteboarding')" | |
59 | |
60 echo ${confcmd} | |
61 ${confcmd} || die "configure failed" | |
62 ## Makefile is not always created... | |
63 #[[ ! -f Makefile ]] && die "configure failed" | |
64 } | |
65 | |
66 pkg_preinst() { | |
67 gnome2_icon_savelist | |
68 } | |
69 | |
70 pkg_postinst() { | |
71 gnome2_icon_cache_update | |
72 } | |
73 | |
74 pkg_postrm() { | |
75 gnome2_icon_cache_update | |
76 } |