comparison net-im/psi-plus/psi-plus-0.16.449.ebuild @ 382:31a33e308598

add build support for selected plugins
author Dirk Olmes <dirk@xanthippe.ping.de>
date Thu, 12 Mar 2015 04:16:10 +0100
parents cf8e0286cc7d
children
comparison
equal deleted inserted replaced
381:cf8e0286cc7d 382:31a33e308598
10 S="${WORKDIR}/psi-plus-snapshots-${PV}" 10 S="${WORKDIR}/psi-plus-snapshots-${PV}"
11 11
12 LICENSE="GPL-2" 12 LICENSE="GPL-2"
13 SLOT="0" 13 SLOT="0"
14 KEYWORDS="~amd64 ~x86" 14 KEYWORDS="~amd64 ~x86"
15 IUSE="crypt dbus debug doc jingle plugins spell ssl xscreensaver whiteboarding" 15 IUSE="autoreplyplugin crypt dbus debug doc jingle otrplugin plugins spell ssl xscreensaver watcherplugin whiteboarding"
16 #RESTRICT="test" 16 #RESTRICT="test"
17 17
18 RDEPEND="app-arch/unzip 18 RDEPEND="app-arch/unzip
19 >=dev-qt/qtgui-4.7:4 19 >=dev-qt/qtgui-4.7:4
20 >=app-crypt/qca-2.0.2:2[qt4(+)] 20 >=app-crypt/qca-2.0.2:2[qt4(+)]
30 doc? ( app-doc/doxygen )" 30 doc? ( app-doc/doxygen )"
31 31
32 PDEPEND="crypt? ( app-crypt/qca:2[gpg] ) 32 PDEPEND="crypt? ( app-crypt/qca:2[gpg] )
33 jingle? ( net-im/psimedia 33 jingle? ( net-im/psimedia
34 app-crypt/qca:2[openssl] ) 34 app-crypt/qca:2[openssl] )
35 ssl? ( app-crypt/qca:2[openssl] )" 35 ssl? ( app-crypt/qca:2[openssl] )
36 otrplugin? ( net-libs/libotr app-text/htmltidy )"
36 37
37 src_prepare() { 38 src_prepare() {
38 epatch_user 39 epatch_user
39 } 40 }
40 41
57 ${confcmd} || die "configure failed" 58 ${confcmd} || die "configure failed"
58 ## Makefile is not always created... 59 ## Makefile is not always created...
59 #[[ ! -f Makefile ]] && die "configure failed" 60 #[[ ! -f Makefile ]] && die "configure failed"
60 } 61 }
61 62
63 src_compile() {
64 emake || die "emake failed"
65
66 if use autoreplyplugin; then
67 cd src/plugins/generic/autoreplyplugin
68 qmake
69 make
70 cd ../../../..
71 fi
72
73 if use otrplugin; then
74 cd src/plugins/generic/otrplugin
75 qmake
76 make
77 cd ../../../..
78 fi
79
80 if use watcherplugin; then
81 cd src/plugins/generic/watcherplugin
82 qmake
83 make
84 cd ../../../..
85 fi
86 }
87
88 src_install() {
89 emake DESTDIR="${D}" INSTALL_ROOT="${D}" install
90 dodoc README TODO ChangeLog
91
92 if use autoreplyplugin; then
93 cd src/plugins/generic/autoreplyplugin
94
95 local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
96 dodir "${plugindir}"
97 insinto "${plugindir}"
98 doins libautoreplyplugin.so
99
100 cd ../../../..
101 fi
102
103 if use otrplugin; then
104 cd src/plugins/generic/otrplugin
105
106 local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
107 dodir "${plugindir}"
108 insinto "${plugindir}"
109 doins libotrplugin.so
110
111 cd ../../../..
112 fi
113
114 if use watcherplugin; then
115 cd src/plugins/generic/watcherplugin
116
117 local plugindir="/usr/$(get_libdir)/psi-plus/plugins"
118 dodir "${plugindir}"
119 insinto "${plugindir}"
120 doins libwatcherplugin.so
121
122 cd ../../../..
123 fi
124 }
125
62 pkg_preinst() { 126 pkg_preinst() {
63 gnome2_icon_savelist 127 gnome2_icon_savelist
64 } 128 }
65 129
66 pkg_postinst() { 130 pkg_postinst() {