comparison app-crypt/veracrypt/veracrypt-1.18a.ebuild @ 417:3498ce732053

add latest veracrypt ebuild
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 26 Aug 2016 10:05:29 +0200
parents
children
comparison
equal deleted inserted replaced
416:4f08c70120b9 417:3498ce732053
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Id$
4
5 EAPI="5"
6 WX_GTK_VER="3.0"
7
8 inherit unpacker wxwidgets
9
10 DESCRIPTION="VeraCrypt is a free disk encryption software based on TrueCrypt"
11 HOMEPAGE="https://veracrypt.codeplex.com"
12 SRC_URI="https://github.com/veracrypt/VeraCrypt/archive/VeraCrypt_${PV}.tar.gz -> ${P}.tar.gz"
13
14 LICENSE="truecrypt-3.0"
15 SLOT="0"
16 KEYWORDS="~amd64"
17 IUSE=""
18
19
20 RESTRICT="mirror"
21
22 DEPEND="
23 sys-devel/make
24 dev-lang/nasm
25 app-arch/makeself
26 sys-fs/fuse
27 x11-libs/wxGTK:${WX_GTK_VER}[X]
28 "
29
30 RDEPEND="${DEPEND}"
31
32 S=${WORKDIR}
33
34 src_unpack() {
35 unpack ${A} || die "Could not unpack!"
36 mv ${WORKDIR}/* ${WORKDIR}/${PN} || die "Could not move directory!"
37 return
38 }
39
40 src_compile() {
41 cd ${WORKDIR}/${PN}/src
42 make || die "Could not make VeraCrypt!"
43 return
44 }
45
46 src_install() {
47 exeinto /usr/bin
48 doexe ${WORKDIR}/${PN}/src/Main/veracrypt || die "Could not install veracrypt executable!"
49 insinto /usr/share/pixmaps
50 doins "${FILESDIR}"/veracrypt.png || die "Could not copy veracrypt.png"
51 return
52 }
53
54 pkg_postinst() {
55 xdg-desktop-menu install --novendor "${FILESDIR}"/veracrypt.desktop || die "Could not register a menu item!"
56 return
57 }
58
59 pkg_postrm() {
60 xdg-desktop-menu uninstall "${FILESDIR}"/veracrypt.desktop || die "Could not de-register a menu item!"
61 return
62 }