Mercurial > hg > portage
comparison dev-java/maven-bin/maven-bin-3.0.1.ebuild @ 281:34ae6a0a3fe8
pull all the latest changes from Holgi
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 01 Apr 2011 17:58:34 +0200 |
parents | f51192bf65dd |
children |
comparison
equal
deleted
inserted
replaced
280:8679a9a2a216 | 281:34ae6a0a3fe8 |
---|---|
1 # Copyright 1999-2010 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/dev-java/maven-bin/maven-bin-2.2.1.ebuild,v 1.3 2010/04/26 11:05:56 phajdan.jr Exp $ | |
4 | |
5 inherit java-pkg-2 | |
6 inherit versionator | |
7 | |
8 MY_P="apache-maven-3.0.1" | |
9 | |
10 DESCRIPTION="Project Management and Comprehension Tool for Java" | |
11 SRC_URI="mirror://apache/maven/binaries/${MY_P}-bin.tar.gz" | |
12 HOMEPAGE="http://maven.apache.org/" | |
13 LICENSE="Apache-2.0" | |
14 SLOT="3.0" | |
15 KEYWORDS="~amd64 ~ppc ~x86" | |
16 | |
17 RDEPEND=">=virtual/jdk-1.5 | |
18 app-admin/eselect-maven" | |
19 | |
20 IUSE="" | |
21 | |
22 S="${WORKDIR}/${MY_P}" | |
23 | |
24 MAVEN=${PN}-${SLOT} | |
25 MAVEN_SHARE="/usr/share/${MAVEN}" | |
26 | |
27 src_unpack() { | |
28 unpack ${A} | |
29 | |
30 rm -v "${S}"/bin/*.bat || die | |
31 } | |
32 | |
33 src_install() { | |
34 dodir "${MAVEN_SHARE}" | |
35 cp -Rp bin boot conf lib "${D}/${MAVEN_SHARE}" || die "failed to copy" | |
36 | |
37 java-pkg_regjar "${D}/${MAVEN_SHARE}"/lib/*.jar | |
38 | |
39 # the Maven distro comes with really weird permissions in the tarball | |
40 # which will cause the ebuild to preserve these weird permissions, leaving | |
41 # users with a broken maven installationy | |
42 chown root: "${D}/${MAVEN_SHARE}"/lib/*.jar "${D}/${MAVEN_SHARE}"/boot/*.jar | |
43 chmod 644 "${D}/${MAVEN_SHARE}"/lib/*.jar "${D}/${MAVEN_SHARE}"/boot/*.jar | |
44 | |
45 dodoc NOTICE.txt README.txt || die | |
46 | |
47 dodir /usr/bin | |
48 dosym "${MAVEN_SHARE}/bin/mvn" /usr/bin/mvn-${SLOT} | |
49 } | |
50 |