comparison www-apps/serendipity/serendipity-1.5.5.ebuild @ 281:34ae6a0a3fe8

pull all the latest changes from Holgi
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 01 Apr 2011 17:58:34 +0200
parents c9d209e62e25
children
comparison
equal deleted inserted replaced
280:8679a9a2a216 281:34ae6a0a3fe8
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit webapp depend.php
6
7 DESCRIPTION="PHP-powered, flexible blogging/CMS application."
8 HOMEPAGE="http://www.s9y.org/"
9 SRC_URI="mirror://sourceforge/php-blog/${P}.tar.gz"
10
11 LICENSE="BSD"
12 KEYWORDS="~amd64 ~x86"
13 IUSE="imagemagick"
14
15 DEPEND=""
16 RDEPEND="virtual/httpd-cgi
17 imagemagick? ( media-gfx/imagemagick )"
18
19 need_php_httpd
20
21 S="${WORKDIR}/${PN}"
22
23 pkg_setup() {
24 webapp_pkg_setup
25
26 if ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli postgres sqlite \
27 || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external \
28 || ! PHPCHECKNODIE="yes" require_php_with_use iconv unicode xml zlib ; then
29 eerror
30 eerror "${PHP_PKG} needs to be reinstalled at least one of mysql, mysqli,"
31 eerror "postgres or sqlite USE flags enabled for a database backend."
32 eerror "It must also have either gd or gd-external USE flag enabled."
33 eerror "It must also have all of iconv pcre unicode xml zlib USE flags enabled."
34 die "Reinstall ${PHP_PKG} with the above-stated USE flags."
35 fi
36 }
37
38 src_install() {
39 webapp_src_preinst
40
41 rm docs/INSTALL*
42 local docs="docs/*"
43 dodoc ${docs}
44 rm -rf docs/
45
46 einfo "Installing application files."
47 cp -r . "${D}"${MY_HTDOCSDIR}
48 touch "${D}"${MY_HTDOCSDIR}/.htaccess
49 touch "${D}"${MY_HTDOCSDIR}/serendipity_config_local.inc.php
50
51 keepdir ${MY_HTDOCSDIR}/archives/
52 webapp_configfile ${MY_HTDOCSDIR}/serendipity_config_local.inc.php
53 #webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
54
55 # archives, templates_c and uploads need to be writable to PHP
56 # .htaccess amd serendipity_config_local.inc.php need to be too
57 # plugins and templates need to be writable for spartacus support.
58 local SERVEROWNED="serendipity_config_local.inc.php .htaccess archives plugins templates templates_c uploads"
59 for SFILES in ${SERVEROWNED}; do
60 webapp_serverowned ${MY_HTDOCSDIR}/${SFILES}
61 done
62
63 webapp_src_install
64 }