comparison app-arch/pigz/pigz-2.1.5.ebuild @ 174:3b3ba42f2f0e

pigz-2.1.5 symlink bugfix & support for gzip symlink
author holger
date Sat, 14 Nov 2009 03:27:58 +0100
parents
children 9839e927aee2
comparison
equal deleted inserted replaced
173:a34dd751aba9 174:3b3ba42f2f0e
1 # Copyright 1999-2009 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/pigz-2.1.5.ebuild,v 1.2 2009/11/02 17:58:48 vostorga Exp $
4
5 inherit eutils toolchain-funcs
6
7 DESCRIPTION="A parallel implementation of gzip."
8 HOMEPAGE="http://www.zlib.net/pigz/"
9 SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz"
10
11 LICENSE="PIGZ"
12 SLOT="0"
13 KEYWORDS="~amd64 ~sparc ~x86"
14 IUSE="test symlink"
15
16 RDEPEND="sys-libs/zlib"
17 DEPEND="${RDEPEND}
18 test? ( app-arch/ncompress )"
19
20 src_unpack() {
21 unpack ${A}
22 epatch "${FILESDIR}"/${P}-respect-flags.patch
23 epatch "${FILESDIR}"/${P}-decode-symlinks-to-stdout.patch
24 }
25
26 src_compile() {
27 tc-export CC
28 emake || die "make failed"
29 }
30
31 src_install() {
32 dobin ${PN} || die "Failed to install"
33 dosym /usr/bin/pigz /usr/bin/unpigz
34 dodoc README
35
36 if use symlink; then
37 dosym /usr/bin/pigz /usr/bin/gzip
38 fi
39 }