comparison mail-client/alpine/alpine-2.00.ebuild @ 77:3d2e64e09140

bump alpine to 2.0
author holger@hoho.dyndns.org
date Wed, 27 Aug 2008 14:27:14 +0200
parents
children 47db27a12ba2
comparison
equal deleted inserted replaced
76:f7de040b797f 77:3d2e64e09140
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="alpine is the successor of the famous mail and news reader pine"
8 HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/"
9 SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2
10 chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz )"
11
12 LICENSE="Apache-2.0"
13 SLOT="0"
14 KEYWORDS="~x86 ~amd64 ~x86-fbsd"
15 IUSE="chappa doc ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads topal userland_BSD"
16
17 DEPEND="virtual/pam
18 >=sys-libs/ncurses-5.1
19 ssl? ( dev-libs/openssl )
20 ldap? ( net-nds/openldap )
21 kerberos? ( app-crypt/mit-krb5 )
22 spell? ( app-text/aspell )
23 topal? ( >=mail-client/topal-62 )"
24 RDEPEND="${DEPEND}
25 app-misc/mime-types
26 !onlyalpine? ( !app-editors/pico )
27 !onlyalpine? ( !mail-client/pine )
28 !<=net-mail/uw-imap-2004g"
29
30 maildir_warn() {
31 elog
32 elog "This build of ${PN} has Maildir support built in as"
33 elog "part of the chappa-all patch."
34 elog
35 elog "If you have a maildir at ~/Maildir it will be your"
36 elog "default INBOX. The path may be changed with the"
37 elog "\"maildir-location\" setting in alpine."
38 elog
39 elog "To use /var/spool/mail INBOX again, set"
40 elog "\"disable-these-drivers=md\" in your .pinerc file."
41 elog
42 elog "Alternately, you might want to read following webpage, which explains how to"
43 elog "use multiple mailboxes simultaneously:"
44 elog
45 elog "http://www.math.washington.edu/~chappa/pine/pine-info/collections/incoming-folders/"
46 elog
47 }
48
49 src_unpack() {
50 unpack ${A}
51 use chappa && epatch "${WORKDIR}"/all.patch
52 # topal needs updating for alpine 2.00
53 #use topal && epatch /usr/share/topal/patches/${P}.patch
54 use topal && die "topal needs updating for ${P}. Please disable it for now."
55 }
56
57 src_compile() {
58 local myconf="--without-tcl
59 --with-system-pinerc=/etc/pine.conf
60 --with-system-fixed-pinerc=/etc/pine.conf.fixed
61 --with-ssl-certs-dir=/etc/ssl/certs"
62
63 use ssl || myconf="${myconf} --without-ssl"
64 use ldap || myconf="${myconf} --without-ldap"
65 use passfile && myconf="${myconf} --with-passfile=.pinepwd"
66 use kerberos || myconf="${myconf} --without-krb5"
67 use threads || myconf="${myconf} --without-pthread"
68 use spell && myconf="${myconf} --with-interactive-spellcheck=/usr/bin/aspell"
69 use nls || myconf="${myconf} --disable-nls"
70 use ipv6 || myconf="${myconf} --without-ipv6"
71 use smime || myconf="${myconf} --without-smime"
72
73 # fixme
74 # --with-system-mail-directory=DIR?
75
76 econf ${myconf} || die "configure problem"
77
78 use userland_BSD && make || emake
79 }
80
81 src_install() {
82 if use onlyalpine; then
83 dobin alpine/alpine
84 doman doc/alpine.1
85 else
86 if use userland_BSD; then
87 make DESTDIR="${D}" install
88 else
89 emake DESTDIR="${D}" install
90 fi
91
92 doman doc/rpdump.1 doc/rpload.1
93 fi
94
95 dodoc NOTICE
96 if use chappa; then
97 dodoc README.maildir
98 fi
99
100 if use doc; then
101 dodoc README doc/brochure.txt doc/tech-notes.txt
102 docinto imap
103 dodoc imap/docs/*.txt imap/docs/CONFIG imap/docs/RELNOTES
104
105 docinto imap/rfc
106 dodoc imap/docs/rfc/*.txt
107
108 docinto html/tech-notes
109 dohtml -r doc/tech-notes/
110 fi
111 }
112
113 pkg_postinst() {
114 use chappa && maildir_warn
115 if use spell; then
116 elog
117 elog "In order to use spell checking"
118 elog " emerge app-dicts/aspell-\<your_langs\>"
119 elog "and setup alpine with:"
120 elog " Speller = /usr/bin/aspell -c"
121 elog
122 fi
123 if use topal; then
124 elog
125 elog "In order to use gpg with topal"
126 elog " read /usr/doc/topal/README.txt"
127 elog
128 fi
129 if use passfile ; then
130 elog
131 elog "${PN} will cache passwords between connections."
132 elog "File ~/.pinepw will be used for this."
133 elog
134 fi
135 }