Mercurial > hg > portage
comparison mail-client/alpine/alpine-2.00.ebuild @ 78:47db27a12ba2
fix alpine build for --as-needed in LDFLAGS
author | holger@hoho.dyndns.org |
---|---|
date | Wed, 27 Aug 2008 20:38:51 +0200 |
parents | 3d2e64e09140 |
children |
comparison
equal
deleted
inserted
replaced
77:3d2e64e09140 | 78:47db27a12ba2 |
---|---|
1 # Copyright 1999-2008 Gentoo Foundation | 1 # Copyright 1999-2008 Gentoo Foundation |
2 # Distributed under the terms of the GNU General Public License v2 | 2 # Distributed under the terms of the GNU General Public License v2 |
3 # $Header: $ | 3 # $Header: $ |
4 | 4 |
5 inherit eutils | 5 inherit eutils flag-o-matic |
6 | 6 |
7 DESCRIPTION="alpine is the successor of the famous mail and news reader pine" | 7 DESCRIPTION="alpine is the successor of the famous mail and news reader pine" |
8 HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/" | 8 HOMEPAGE="http://www.washington.edu/alpine/ http://staff.washington.edu/chappa/alpine/" |
9 SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2 | 9 SRC_URI="ftp://ftp.cac.washington.edu/alpine/${P}.tar.bz2 |
10 chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz )" | 10 chappa? ( http://staff.washington.edu/chappa/alpine/patches/${P}/all.patch.gz )" |
71 use smime || myconf="${myconf} --without-smime" | 71 use smime || myconf="${myconf} --without-smime" |
72 | 72 |
73 # fixme | 73 # fixme |
74 # --with-system-mail-directory=DIR? | 74 # --with-system-mail-directory=DIR? |
75 | 75 |
76 econf ${myconf} || die "configure problem" | 76 # fixme |
77 # --as-needed breaks linking of c-client for executables | |
78 # filter-ldflags --as-needed does not work for "-Wl,-O1,--as-needed,-z,now" ?? | |
79 LDFLAGS=`echo $LDFLAGS | sed s/--as-needed//g | sed s/,,/,/g` | |
80 econf ${myconf} LDFLAGS="$LDFLAGS" || die "configure problem" | |
77 | 81 |
78 use userland_BSD && make || emake | 82 if use userland_BSD; then |
83 make || die "make failed" | |
84 else | |
85 emake || die "emake failed" | |
86 fi | |
79 } | 87 } |
80 | 88 |
81 src_install() { | 89 src_install() { |
82 if use onlyalpine; then | 90 if use onlyalpine; then |
83 dobin alpine/alpine | 91 dobin alpine/alpine |