comparison net-misc/e1000e/e1000e-0.4.1.7.ebuild @ 57:4cd1ebbb3297

pull changes from Holgi's portage repository
author Dirk Olmes <dirk@xanthippe.ping.de>
date Sun, 10 Aug 2008 01:32:42 +0200
parents 5f7d8fd4d921
children
comparison
equal deleted inserted replaced
51:665fb2df350f 57:4cd1ebbb3297
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
5 HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
6 LICENSE="GPL-2"
7 DEPEND="virtual/linux-sources"
8
9 SRC_URI="mirror://sourceforge/e1000/${P}.tar.gz"
10 SLOT="0"
11 KEYWORDS="x86"
12 IUSE=""
13
14
15 src_unpack() {
16 unpack ${A}
17 cd ${S}/src
18 # rem out the DEPVER line, since it would cause a sandbox violation and
19 # since it is only needed by RPM ;-)
20 sed -i "/^DEPVER :=/ d" Makefile
21 }
22
23
24 src_compile() {
25 check_KV
26 cd "${S}/src"
27
28 # workaround needed for some ethernet controllers to work with low end switches
29 if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
30 then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
31 else CFLAGS_EXTRA=""
32 fi
33
34 make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
35 }
36
37
38 src_install() {
39 insinto "/lib/modules/${KV}/kernel/drivers/net/e1000e"
40 doins "${S}/src/e1000e.ko"
41 doman e1000e.7
42 dodoc COPYING README SUMS e1000e.spec
43 einfo ""
44 einfo "In case you have problems when loading the module, try to run depmod -A"
45 einfo ""
46 }