Mercurial > hg > portage
comparison net-im/skype/skype-2.1.0.47-r1.ebuild @ 188:53e0b4793285
Skype 2.1.0.47 aus der Portage reaktiviert
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Tue, 23 Feb 2010 09:11:07 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
187:b2a0a67c29a5 | 188:53e0b4793285 |
---|---|
1 # Copyright 1999-2010 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/www/viewcvs.gentoo.org/raw_cvs/gentoo-x86/net-im/skype/Attic/skype-2.1.0.47-r1.ebuild,v 1.2 2010/01/23 17:17:01 ssuominen dead $ | |
4 | |
5 EAPI=2 | |
6 | |
7 inherit eutils qt4 pax-utils | |
8 | |
9 DESCRIPTION="A P2P-VoiceIP client." | |
10 HOMEPAGE="http://www.skype.com/" | |
11 | |
12 SFILENAME=${PN}_static-${PV}.tar.bz2 | |
13 DFILENAME=${P}.tar.bz2 | |
14 SRC_URI="!qt-static? ( http://download.skype.com/linux/${DFILENAME} ) | |
15 qt-static? ( http://download.skype.com/linux/${SFILENAME} )" | |
16 | |
17 LICENSE="skype-eula" | |
18 SLOT="0" | |
19 KEYWORDS="~amd64 ~x86" | |
20 IUSE="qt-static" | |
21 | |
22 # http://bugs.gentoo.org/show_bug.cgi?id=299368 | |
23 RESTRICT="mirror strip" | |
24 | |
25 EMUL_VER=20091231 | |
26 | |
27 RDEPEND="amd64? ( >=app-emulation/emul-linux-x86-xlibs-${EMUL_VER} | |
28 >=app-emulation/emul-linux-x86-baselibs-${EMUL_VER} | |
29 >=app-emulation/emul-linux-x86-soundlibs-${EMUL_VER} | |
30 !qt-static? ( >=app-emulation/emul-linux-x86-qtlibs-${EMUL_VER} ) ) | |
31 x86? ( >=media-libs/alsa-lib-1.0.11 | |
32 x11-libs/libXScrnSaver | |
33 x11-libs/libXv | |
34 qt-static? ( media-libs/fontconfig | |
35 media-libs/freetype | |
36 x11-libs/libICE | |
37 x11-libs/libSM | |
38 x11-libs/libXcursor | |
39 x11-libs/libXext | |
40 x11-libs/libXfixes | |
41 x11-libs/libXi | |
42 x11-libs/libXinerama | |
43 x11-libs/libXrandr | |
44 x11-libs/libXrender | |
45 x11-libs/libX11 ) | |
46 !qt-static? ( x11-libs/qt-gui:4[accessibility,dbus] | |
47 x11-libs/qt-dbus:4 | |
48 x11-libs/libX11 | |
49 x11-libs/libXau | |
50 x11-libs/libXdmcp ) )" | |
51 | |
52 # Required for lrelease command at buildtime | |
53 DEPEND="!qt-static? ( x11-libs/qt-core:4 )" | |
54 | |
55 QA_EXECSTACK="opt/skype/skype" | |
56 QA_WX_LOAD="opt/skype/skype" | |
57 QA_DT_HASH="opt/skype/skype" | |
58 QA_PRESTRIPPED="opt/skype/skype" | |
59 | |
60 use qt-static && S="${WORKDIR}/${PN}_static-${PV}" | |
61 | |
62 src_install() { | |
63 # remove mprotect() restrictions for PaX usage - see Bug 100507 | |
64 # NOTE. Commented out because it's breaking Skype 2.1.0.47. | |
65 # pax-mark m "${S}"/skype | |
66 | |
67 exeinto /opt/${PN} | |
68 doexe skype || die | |
69 fowners root:audio /opt/skype/skype | |
70 make_wrapper skype /opt/${PN}/skype /opt/${PN} /opt/${PN} /usr/bin | |
71 | |
72 insinto /opt/${PN}/sounds | |
73 doins sounds/*.wav || die | |
74 | |
75 if ! use qt-static ; then | |
76 insinto /etc/dbus-1/system.d | |
77 doins ${PN}.conf || die | |
78 fi | |
79 | |
80 insinto /opt/${PN}/lang | |
81 # | |
82 #There have been some issues were lang is not updated from the .ts files | |
83 #but if we have qt we can rebuild it | |
84 # | |
85 if ! use qt-static ; then | |
86 lrelease lang/*.ts | |
87 fi | |
88 | |
89 doins lang/*.qm || die | |
90 | |
91 insinto /opt/${PN}/avatars | |
92 doins avatars/*.png || die | |
93 | |
94 insinto /opt/${PN} | |
95 for X in 16 32 48 | |
96 do | |
97 insinto /usr/share/icons/hicolor/${X}x${X}/apps | |
98 newins "${S}"/icons/SkypeBlue_${X}x${X}.png ${PN}.png | |
99 done | |
100 | |
101 dodoc README | |
102 | |
103 # insinto /usr/share/applications/ | |
104 # doins skype.desktop | |
105 make_desktop_entry ${PN} "Skype VoIP" ${PN} "Network;InstantMessaging;Telephony" | |
106 | |
107 #Fix for no sound notifications | |
108 dosym /opt/${PN} /usr/share/${PN} | |
109 | |
110 # TODO: Optional configuration of callto:// in KDE, Mozilla and friends | |
111 # doexe skype-callto-handler | |
112 } |