comparison net-misc/e1000/e1000-8.0.3.1.ebuild @ 53:5f7d8fd4d921

revbumps for e1000/e1000e
author holger@hoho.dyndns.org
date Fri, 04 Jul 2008 14:37:06 +0200
parents net-misc/e1000/e1000-8.0.1.ebuild@bbf2357b3c0d
children
comparison
equal deleted inserted replaced
52:021734360017 53:5f7d8fd4d921
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 DESCRIPTION="Kernel driver for Intel Pro/1000 ethernet adapters."
5 HOMEPAGE="http://support.intel.com/support/network/adapter/1000/index.htm"
6 LICENSE="GPL-2"
7 DEPEND="virtual/linux-sources"
8
9 SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
10 SLOT="0"
11 KEYWORDS="x86"
12 IUSE=""
13
14
15 src_unpack() {
16 unpack ${A}
17 cd ${S}/src
18 # rem out the DEPVER line, since it would cause a sandbox violation and
19 # since it is only needed by RPM ;-)
20 sed -i "/^DEPVER :=/ d" Makefile
21 }
22
23
24 src_compile() {
25 check_KV
26 cd "${S}/src"
27
28 # workaround needed for some ethernet controllers to work with low end switches
29 if [[ ${USE_INCOMPATIBLE_SWITCH} ]]
30 then CFLAGS_EXTRA="CFLAGS_EXTRA=-DE_1000_MASTER_SLAVE=1"
31 else CFLAGS_EXTRA=""
32 fi
33
34 make ${CFLAGS_EXTRA} KSRC=/usr/src/linux
35 }
36
37
38 src_install() {
39 insinto "/lib/modules/${KV}/kernel/drivers/net/e1000"
40 doins "${S}/src/e1000.ko"
41 doman e1000.7
42 dodoc LICENSE README SUMS e1000.spec ldistrib.txt ${FILESDIR}/README.Gentoo
43 einfo ""
44 einfo "In case you have problems when loading the module, try to run depmod -A"
45 einfo ""
46 einfo "If you experience problems with low-end switches, read"
47 einfo "/usr/share/doc/${PF}/README.Gentoo.gz for a possible workaround"
48 einfo ""
49 }