Mercurial > hg > portage
comparison media-video/openshot/openshot-1.4.3.ebuild @ 356:627e480843ea
add an openshot ebuild
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Mon, 16 Jun 2014 06:53:32 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
355:b5842c196f43 | 356:627e480843ea |
---|---|
1 # Copyright 1999-2012 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: $ | |
4 | |
5 EAPI=3 | |
6 | |
7 PYTHON_DEPEND=2:2.5 | |
8 PYTHON_USE_WITH=xml | |
9 | |
10 inherit versionator distutils fdo-mime | |
11 | |
12 DESCRIPTION="OpenShot Video Editor is a non-linear video editor" | |
13 HOMEPAGE="http://www.openshotvideo.com" | |
14 SRC_URI="http://launchpad.net/openshot/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz" | |
15 | |
16 LICENSE="GPL-3" | |
17 SLOT="0" | |
18 KEYWORDS="~amd64 ~x86" | |
19 IUSE="" | |
20 | |
21 DEPEND="" | |
22 RDEPEND=" | |
23 x11-libs/gtk+:2 | |
24 dev-python/pygtk | |
25 dev-python/pygoocanvas | |
26 dev-python/pyxdg | |
27 dev-python/librsvg-python | |
28 dev-python/httplib2 | |
29 media-libs/mlt[ffmpeg,frei0r,gtk,melt,python,sdl,xml] | |
30 media-sound/sox[encode,ffmpeg] | |
31 >=virtual/ffmpeg-0.6[encode,sdl] | |
32 virtual/python-imaging | |
33 " | |
34 #>=virtual/ffmpeg-0.6[encode,faac?,ieee1394?,mp3?,sdl,theora?,vorbis?,vpx,x264?,xvid?] | |
35 pkg_setup() { | |
36 python_set_active_version 2 | |
37 python_pkg_setup | |
38 } | |
39 | |
40 src_prepare() { | |
41 python_convert_shebangs -q -r 2 . | |
42 distutils_src_prepare | |
43 | |
44 # Disable the installation of the mime.types file. | |
45 # The .desktop file would be used to update the mime database. | |
46 sed -ie '/launcher/,+1d' setup.py || die | |
47 | |
48 # Avoid stuff covered by fdo-mime.eclass | |
49 # (update-mime-database update-desktop-database update-mime) | |
50 # export "FAKEROOTKEY=gentoo" does not work as this variable is filtered | |
51 # by portage | |
52 sed -ie '/FAILED = /,$d' setup.py || die | |
53 } | |
54 | |
55 # TODO: check stuff installed to /usr/lib/python2.6/site-packages as there are | |
56 # some parts installed which shouldn't (locale, themes, profiles effects, | |
57 # etc...) Afaik only python stuff should go there and the rest probably to | |
58 # /usr/share/openshot | |
59 # The same goes for /usr/lib/mime/packages | |
60 | |
61 pkg_postinst() { | |
62 fdo-mime_mime_database_update | |
63 fdo-mime_desktop_database_update | |
64 distutils_pkg_postinst | |
65 } | |
66 | |
67 pkg_postrm() { | |
68 fdo-mime_mime_database_update | |
69 fdo-mime_desktop_database_update | |
70 distutils_pkg_postrm | |
71 } |