Mercurial > hg > portage
comparison net-misc/icaclient/icaclient-19.10.0.15.ebuild @ 487:6df6fb0af440
ebuild for newer citrix desktop client
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Tue, 08 Oct 2019 10:06:50 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
486:6ed1ab937e60 | 487:6df6fb0af440 |
---|---|
1 # Copyright 1999-2019 Gentoo Authors | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI=7 | |
5 | |
6 # eutils inherit required for make_wrapper call | |
7 inherit desktop eutils multilib xdg-utils | |
8 | |
9 DESCRIPTION="ICA Client for Citrix Presentation servers" | |
10 HOMEPAGE="https://www.citrix.com/" | |
11 SRC_URI="amd64? ( linuxx64-${PV}.tar.gz )" | |
12 | |
13 LICENSE="icaclient" | |
14 SLOT="0" | |
15 KEYWORDS="-* ~amd64" | |
16 IUSE="l10n_de l10n_es l10n_fr l10n_ja l10n_zh-CN" | |
17 RESTRICT="mirror strip userpriv fetch" | |
18 | |
19 ICAROOT="/opt/Citrix/ICAClient" | |
20 | |
21 QA_PREBUILT="${ICAROOT#/}/*" | |
22 | |
23 RDEPEND=" | |
24 dev-libs/atk | |
25 dev-libs/glib:2 | |
26 dev-libs/libxml2 | |
27 media-fonts/font-adobe-100dpi | |
28 media-fonts/font-misc-misc | |
29 media-fonts/font-cursor-misc | |
30 media-fonts/font-xfree86-type1 | |
31 media-fonts/font-misc-ethiopic | |
32 media-libs/alsa-lib | |
33 media-libs/fontconfig | |
34 media-libs/freetype | |
35 media-libs/gst-plugins-base:1.0 | |
36 media-libs/gstreamer:1.0 | |
37 media-libs/libogg | |
38 media-libs/libvorbis | |
39 media-libs/speex | |
40 net-libs/libsoup:2.4 | |
41 net-libs/webkit-gtk:4 | |
42 net-misc/curl | |
43 sys-libs/e2fsprogs-libs | |
44 sys-libs/zlib | |
45 virtual/krb5 | |
46 virtual/jpeg:0 | |
47 x11-libs/cairo | |
48 x11-libs/gdk-pixbuf:2 | |
49 x11-libs/gtk+:2 | |
50 x11-libs/gtk+:3 | |
51 x11-libs/libX11 | |
52 x11-libs/libXaw | |
53 x11-libs/libXext | |
54 x11-libs/libXfixes | |
55 x11-libs/libXinerama | |
56 x11-libs/libXmu | |
57 x11-libs/libXrender | |
58 x11-libs/libXt | |
59 x11-libs/pango | |
60 " | |
61 DEPEND="" | |
62 | |
63 pkg_nofetch() { | |
64 elog "Download the client file ${A} from | |
65 https://www.citrix.com/downloads/workspace-app/" | |
66 elog "and place it into your DISTDIR directory." | |
67 } | |
68 | |
69 pkg_setup() { | |
70 case ${ARCH} in | |
71 amd64) | |
72 ICAARCH=linuxx64 | |
73 ;; | |
74 *) | |
75 eerror "Given architecture is not supported by Citrix." | |
76 ;; | |
77 esac | |
78 | |
79 S="${WORKDIR}/${ICAARCH}/${ICAARCH}.cor" | |
80 } | |
81 | |
82 src_prepare() { | |
83 default | |
84 rm lib/UIDialogLibWebKit.so || die | |
85 } | |
86 | |
87 src_install() { | |
88 local bin tmpl dest | |
89 | |
90 dodir "${ICAROOT}" | |
91 | |
92 exeinto "${ICAROOT}" | |
93 doexe *.DLL libAnalyticsInterfacePd.so libproxy.so wfica AuthManagerDaemon PrimaryAuthManager selfservice ServiceRecord | |
94 | |
95 exeinto "${ICAROOT}"/lib | |
96 doexe lib/*.so | |
97 | |
98 for dest in "${ICAROOT}"{,/nls/en{,.UTF-8}} ; do | |
99 insinto "${dest}" | |
100 doins nls/en.UTF-8/eula.txt | |
101 done | |
102 | |
103 insinto "${ICAROOT}" | |
104 doins -r usb | |
105 | |
106 insinto "${ICAROOT}"/config | |
107 doins config/* config/.* nls/en/*.ini | |
108 for tmpl in {appsrv,wfclient}.template ; do | |
109 newins nls/en/${tmpl} ${tmpl/template/ini} | |
110 done | |
111 touch "${ED}/${ICAROOT}"/config/.server || die | |
112 | |
113 insinto "${ICAROOT}"/gtk | |
114 doins gtk/* | |
115 | |
116 insinto "${ICAROOT}"/gtk/glade | |
117 doins gtk/glade/* | |
118 | |
119 insinto "${ICAROOT}"/site | |
120 doins -r site/* | |
121 | |
122 dodir "${ICAROOT}"/help | |
123 | |
124 insinto "${ICAROOT}"/config/usertemplate | |
125 doins config/usertemplate/* | |
126 | |
127 local lang LANGCODES=( en ) | |
128 use l10n_de && LANGCODES+=( de ) | |
129 use l10n_es && LANGCODES+=( es ) | |
130 use l10n_fr && LANGCODES+=( fr ) | |
131 use l10n_ja && LANGCODES+=( ja ) | |
132 use l10n_zh-CN && LANGCODES+=( zh_CN ) | |
133 | |
134 for lang in ${LANGCODES[@]} ; do | |
135 insinto "${ICAROOT}"/nls/${lang} | |
136 doins nls/${lang}/* | |
137 | |
138 insinto "${ICAROOT}"/nls/$lang/UTF-8 | |
139 doins nls/${lang}.UTF-8/* | |
140 | |
141 insinto "${ICAROOT}"/nls/${lang}/LC_MESSAGES | |
142 doins nls/${lang}/LC_MESSAGES/* | |
143 | |
144 insinto "${ICAROOT}"/nls/${lang} | |
145 dosym UTF-8 "${ICAROOT}"/nls/${lang}/utf8 | |
146 | |
147 for tmpl in {appsrv,wfclient}.template ; do | |
148 cp "${ED}/${ICAROOT}"/nls/${lang}/${tmpl} \ | |
149 "${ED}/${ICAROOT}"/nls/${lang}/${tmpl/template/ini} \ | |
150 || die | |
151 done | |
152 done | |
153 | |
154 insinto "${ICAROOT}"/nls | |
155 dosym en /opt/Citrix/ICAClient/nls/C | |
156 | |
157 insinto "${ICAROOT}"/icons | |
158 doins icons/* | |
159 | |
160 insinto "${ICAROOT}"/keyboard | |
161 doins keyboard/* | |
162 | |
163 rm -r "${S}"/keystore/cacerts || die | |
164 dosym /etc/ssl/certs "${ICAROOT}"/keystore/cacerts | |
165 | |
166 exeinto "${ICAROOT}"/util | |
167 doexe util/{configmgr,conncenter,gst_play1.0,gst_read1.0,hdxcheck.sh,icalicense.sh,libgstflatstm1.0.so,webcontainer,ctxwebhelper,ctx_rehash,ctx_app_bind} | |
168 doexe util/{lurdump,new_store,nslaunch,pnabrowse,storebrowse,sunraymac.sh,what,xcapture} | |
169 | |
170 # https://bugs.gentoo.org/655922 | |
171 dosym gst_play1.0 "${ICAROOT}"/util/gst_play | |
172 dosym gst_read1.0 "${ICAROOT}"/util/gst_read | |
173 dosym libgstflatstm1.0.so "${ICAROOT}"/util/libgstflatstm.so | |
174 | |
175 doenvd "${FILESDIR}"/10ICAClient | |
176 | |
177 for bin in configmgr conncenter new_store ; do | |
178 make_wrapper ${bin} "${ICAROOT}"/util/${bin} . "${ICAROOT}"/util | |
179 done | |
180 | |
181 for bin in selfservice wfica ; do | |
182 make_wrapper ${bin} "${ICAROOT}"/${bin} . "${ICAROOT}" | |
183 done | |
184 | |
185 dodir /etc/revdep-rebuild/ | |
186 echo "SEARCH_DIRS_MASK=\"${ICAROOT}\"" \ | |
187 > "${ED}"/etc/revdep-rebuild/70icaclient | |
188 | |
189 # 651926 | |
190 domenu "${FILESDIR}"/*.desktop | |
191 } | |
192 | |
193 pkg_postinst() { | |
194 xdg_desktop_database_update | |
195 } | |
196 | |
197 pkg_postrm() { | |
198 xdg_desktop_database_update | |
199 } |