Mercurial > hg > portage
comparison sys-fs/ntfs3g/ntfs3g-1.5130.ebuild @ 89:7360f9380ed4
latest ntfs3g
author | holger@hoho.dyndns.org |
---|---|
date | Sat, 27 Dec 2008 15:19:00 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
88:7c953ae90177 | 89:7360f9380ed4 |
---|---|
1 # Copyright 1999-2008 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/sys-fs/ntfs3g/ntfs3g-1.5012.ebuild,v 1.1 2008/10/23 14:23:59 chutzpah Exp $ | |
4 | |
5 MY_PN="${PN/3g/-3g}" | |
6 MY_P="${MY_PN}-${PV}" | |
7 | |
8 DESCRIPTION="Open source read-write NTFS driver that runs under FUSE" | |
9 HOMEPAGE="http://www.ntfs-3g.org" | |
10 SRC_URI="http://www.ntfs-3g.org/${MY_P}.tgz" | |
11 | |
12 LICENSE="GPL-2" | |
13 SLOT="0" | |
14 KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86" | |
15 IUSE="debug hal suid" | |
16 | |
17 RDEPEND="hal? ( sys-apps/hal )" | |
18 DEPEND="${RDEPEND}" | |
19 | |
20 S="${WORKDIR}/${MY_P}" | |
21 | |
22 src_compile() { | |
23 econf \ | |
24 --docdir="/usr/share/doc/${PF}" \ | |
25 --enable-ldscript \ | |
26 --disable-ldconfig \ | |
27 $(use_enable debug) | |
28 emake || die "emake failed" | |
29 } | |
30 | |
31 src_install() { | |
32 emake DESTDIR="${D}" install || die "install failed" | |
33 | |
34 prepalldocs | |
35 dodoc AUTHORS ChangeLog CREDITS | |
36 | |
37 use suid && fperms u+s "/bin/${MY_PN}" | |
38 | |
39 if use hal; then | |
40 insinto /etc/hal/fdi/policy/ | |
41 doins "${FILESDIR}/10-ntfs3g.fdi" | |
42 fi | |
43 } | |
44 | |
45 pkg_postinst() { | |
46 if use suid; then | |
47 ewarn | |
48 ewarn "You have chosen to install ${PN} with the binary setuid root. This" | |
49 ewarn "means that if there any undetected vulnerabilities in the binary," | |
50 ewarn "then local users may be able to gain root access on your machine." | |
51 ewarn | |
52 fi | |
53 } |