Mercurial > hg > portage
comparison www-apps/serendipity/serendipity-1.6.2.ebuild @ 343:784725f461de
add an ebuild for s9y 1.6.2
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 02 Jan 2013 15:26:08 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
342:df76edd71c4c | 343:784725f461de |
---|---|
1 # Copyright 1999-2007 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: $ | |
4 | |
5 inherit webapp depend.php versionator | |
6 | |
7 DESCRIPTION="PHP-powered, flexible blogging/CMS application." | |
8 HOMEPAGE="http://www.s9y.org/" | |
9 MY_P="${PN}-$(get_version_component_range 1-2)" | |
10 SRC_URI="mirror://sourceforge/php-blog/${MY_P}.tar.gz" | |
11 | |
12 LICENSE="BSD" | |
13 KEYWORDS="~amd64 ~x86" | |
14 IUSE="imagemagick" | |
15 | |
16 DEPEND="" | |
17 RDEPEND="virtual/httpd-cgi | |
18 imagemagick? ( media-gfx/imagemagick )" | |
19 | |
20 need_php_httpd | |
21 | |
22 S="${WORKDIR}/${PN}" | |
23 | |
24 pkg_setup() { | |
25 webapp_pkg_setup | |
26 | |
27 if ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli postgres sqlite \ | |
28 || ! PHPCHECKNODIE="yes" require_php_with_any_use gd gd-external \ | |
29 || ! PHPCHECKNODIE="yes" require_php_with_use iconv unicode xml zlib ; then | |
30 eerror | |
31 eerror "${PHP_PKG} needs to be reinstalled at least one of mysql, mysqli," | |
32 eerror "postgres or sqlite USE flags enabled for a database backend." | |
33 eerror "It must also have either gd or gd-external USE flag enabled." | |
34 eerror "It must also have all of iconv pcre unicode xml zlib USE flags enabled." | |
35 die "Reinstall ${PHP_PKG} with the above-stated USE flags." | |
36 fi | |
37 } | |
38 | |
39 src_install() { | |
40 webapp_src_preinst | |
41 | |
42 rm docs/INSTALL* | |
43 local docs="docs/*" | |
44 dodoc ${docs} | |
45 rm -rf docs/ | |
46 | |
47 einfo "Installing application files." | |
48 cp -r . "${D}"${MY_HTDOCSDIR} | |
49 touch "${D}"${MY_HTDOCSDIR}/.htaccess | |
50 touch "${D}"${MY_HTDOCSDIR}/serendipity_config_local.inc.php | |
51 | |
52 keepdir ${MY_HTDOCSDIR}/archives/ | |
53 webapp_configfile ${MY_HTDOCSDIR}/serendipity_config_local.inc.php | |
54 #webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt | |
55 | |
56 # archives, templates_c and uploads need to be writable to PHP | |
57 # .htaccess amd serendipity_config_local.inc.php need to be too | |
58 # plugins and templates need to be writable for spartacus support. | |
59 local SERVEROWNED="serendipity_config_local.inc.php .htaccess archives plugins templates templates_c uploads" | |
60 for SFILES in ${SERVEROWNED}; do | |
61 webapp_serverowned ${MY_HTDOCSDIR}/${SFILES} | |
62 done | |
63 | |
64 webapp_src_install | |
65 } |