comparison dev-lang/dart/dart-1.19.0.ebuild @ 419:7cc9ca777677

ebuild for latest and greatest dart SDK
author Dirk Olmes <dirk@xanthippe.ping.de>
date Tue, 06 Sep 2016 09:05:12 +0200
parents
children
comparison
equal deleted inserted replaced
418:003d791a5f4d 419:7cc9ca777677
1
2 EAPI=6
3 DESCRIPTION="Dart is an application programming language that’s easy to learn, easy to scale, and deployable everywhere."
4 HOMEPAGE="https://www.dartlang.org"
5 SRC_URI="https://storage.googleapis.com/dart-archive/channels/stable/release/${PV}/sdk/dartsdk-linux-x64-release.zip -> ${P}.zip"
6 SLOT="0"
7 KEYWORDS="amd64"
8 S=${WORKDIR}/dart-sdk
9
10 RDEPEND="sys-libs/glibc"
11
12 src_compile() { :; }
13
14 src_install() {
15 local MY_DEST=/opt/dart-${PV}
16
17 insinto ${MY_DEST}
18 doins -r *
19
20 for x in ${D}${MY_DEST}/bin/*; do
21 if [ -f $x ]; then
22 # fperms implicitly adds ${D} which we had to add for listing above
23 chmod +x $x
24 fi
25 done
26 chmod +x ${D}${MY_DEST}/lib/analysis_server/tool/spec/generate_files
27 chmod +x ${D}${MY_DEST}/lib/analyzer/tool/generate_files
28
29 dosym ${MY_DEST}/bin/dart /opt/bin/dart
30 dosym ${MY_DEST}/bin/pub /opt/bin/pub
31 }