Mercurial > hg > portage
comparison dev-db/postgresql-base/postgresql-base-8.4.1.ebuild @ 160:7ce3014adf4b
sync postgres ebuilds with Gentoo bug#276125, fixes misc. bugs
author | holger |
---|---|
date | Wed, 09 Sep 2009 19:04:40 +0200 |
parents | 9014d136897e |
children |
comparison
equal
deleted
inserted
replaced
159:9014d136897e | 160:7ce3014adf4b |
---|---|
66 } | 66 } |
67 | 67 |
68 src_compile() { | 68 src_compile() { |
69 econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \ | 69 econf --prefix=/usr/$(get_libdir)/postgresql-${SLOT} \ |
70 --datadir=/usr/share/postgresql-${SLOT} \ | 70 --datadir=/usr/share/postgresql-${SLOT} \ |
71 --docdir=/usr/share/doc/postgresql-${SLOT} \ | |
71 --sysconfdir=/etc/postgresql-${SLOT} \ | 72 --sysconfdir=/etc/postgresql-${SLOT} \ |
72 --includedir=/usr/include/postgresql-${SLOT} \ | 73 --includedir=/usr/include/postgresql-${SLOT} \ |
73 --with-locale-dir=/usr/share/postgresql-${SLOT}/locale \ | |
74 --mandir=/usr/share/postgresql-${SLOT}/man \ | 74 --mandir=/usr/share/postgresql-${SLOT}/man \ |
75 --without-docdir \ | |
76 --enable-depend \ | 75 --enable-depend \ |
77 --without-tcl \ | 76 --without-tcl \ |
78 --without-perl \ | 77 --without-perl \ |
79 --without-python \ | 78 --without-python \ |
80 $(use_with readline) \ | 79 $(use_with readline) \ |
102 insinto /usr/include/postgresql-${SLOT}/postmaster | 101 insinto /usr/include/postgresql-${SLOT}/postmaster |
103 doins "${S}"/src/include/postmaster/*.h | 102 doins "${S}"/src/include/postmaster/*.h |
104 dodir /usr/share/postgresql-${SLOT}/man/man1 | 103 dodir /usr/share/postgresql-${SLOT}/man/man1 |
105 tar -zxf "${S}/doc/man.tar.gz" -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1 | 104 tar -zxf "${S}/doc/man.tar.gz" -C "${D}"/usr/share/postgresql-${SLOT}/man man1/{ecpg,pg_config}.1 |
106 | 105 |
106 rm -r "${D}/usr/share/doc/postgresql-${SLOT}/html" | |
107 rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster}.1 | 107 rm "${D}/usr/share/postgresql-${SLOT}/man/man1"/{initdb,ipcclean,pg_controldata,pg_ctl,pg_resetxlog,pg_restore,postgres,postmaster}.1 |
108 dodoc README HISTORY doc/{README.*,TODO,bug.template} | 108 dodoc README HISTORY doc/{README.*,TODO,bug.template} |
109 | 109 |
110 cd "${S}/contrib" | 110 cd "${S}/contrib" |
111 emake DESTDIR="${D}" install || die "emake install failed" | 111 emake DESTDIR="${D}" install || die "emake install failed" |