Mercurial > hg > portage
comparison dev-python/python-sipsimple/python-sipsimple-3.1.1.ebuild @ 445:7e560a7c788b
add the necessary ebuilds to make blink work
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 21 Jul 2017 11:00:48 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
444:20f79c3e04b5 | 445:7e560a7c788b |
---|---|
1 # Copyright 1999-2017 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI="6" | |
5 | |
6 PYTHON_COMPAT=( python2_7 ) | |
7 DISTUTILS_SINGLE_IMPL=1 | |
8 | |
9 inherit distutils-r1 | |
10 | |
11 DESCRIPTION="SIP SIMPLE client SDK is a Software Development Kit" | |
12 HOMEPAGE="http://sipsimpleclient.org" | |
13 SRC_URI="https://github.com/AGProjects/${PN}/archive/release-${PV}.tar.gz" | |
14 S=${WORKDIR}/${PN}-release-${PV} | |
15 | |
16 LICENSE="GPL-3" | |
17 SLOT="0" | |
18 IUSE="libressl" | |
19 | |
20 KEYWORDS="~amd64 ~x86" | |
21 | |
22 CDEPEND=" | |
23 dev-db/sqlite:3 | |
24 !libressl? ( dev-libs/openssl:0[-bindist] ) | |
25 libressl? ( dev-libs/libressl ) | |
26 dev-python/python-application[${PYTHON_USEDEP}] | |
27 media-libs/alsa-lib | |
28 media-libs/libv4l | |
29 media-libs/libvpx | |
30 sys-apps/util-linux | |
31 virtual/ffmpeg | |
32 " | |
33 RDEPEND="${CDEPEND} | |
34 virtual/python-dnspython[${PYTHON_USEDEP}] | |
35 dev-python/python-cjson[${PYTHON_USEDEP}] | |
36 dev-python/python-dateutil[${PYTHON_USEDEP}] | |
37 dev-python/python-eventlib[${PYTHON_USEDEP}] | |
38 dev-python/greenlet[${PYTHON_USEDEP}] | |
39 dev-python/python-gnutls[${PYTHON_USEDEP}] | |
40 dev-python/lxml[${PYTHON_USEDEP}] | |
41 >=dev-python/python-msrplib-0.19.0[${PYTHON_USEDEP}] | |
42 dev-python/python-xcaplib[${PYTHON_USEDEP}] | |
43 dev-python/twisted-core[${PYTHON_USEDEP}] | |
44 dev-python/zope-interface[${PYTHON_USEDEP}] | |
45 " | |
46 DEPEND="${CDEPEND} | |
47 dev-python/cython[${PYTHON_USEDEP}] | |
48 virtual/pkgconfig | |
49 " | |
50 src_compile() { | |
51 chmod +x deps/pjsip/{a,}configure | |
52 python setup.py build_ext | |
53 } | |
54 | |
55 src_install() { | |
56 python setup.py install --home "${D}" --install-purelib="${D}"usr/lib64/python2.7/site-packages --install-platlib="${D}"usr/lib64/python2.7/site-packages --install-scripts="${D}"/usr/bin --install-data="${D}"usr | |
57 } |