Mercurial > hg > portage
comparison dev-python/python-sipsimple/python-sipsimple-3.1.1.ebuild.disabled @ 445:7e560a7c788b
add the necessary ebuilds to make blink work
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 21 Jul 2017 11:00:48 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
444:20f79c3e04b5 | 445:7e560a7c788b |
---|---|
1 # Copyright 1999-2015 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Id$ | |
4 | |
5 EAPI="5" | |
6 | |
7 PYTHON_COMPAT=( python2_7 ) | |
8 | |
9 inherit distutils-r1 | |
10 | |
11 DESCRIPTION="SIP SIMPLE client SDK is a Software Development Kit" | |
12 HOMEPAGE="http://sipsimpleclient.org" | |
13 SRC_URI="https://github.com/AGProjects/python-sipsimple/archive/release-${PV}.tar.gz -> ${P}.tar.gz" | |
14 | |
15 LICENSE="GPL-3" | |
16 SLOT="0" | |
17 IUSE="libressl" | |
18 | |
19 KEYWORDS="~amd64 ~x86" | |
20 | |
21 CDEPEND=" | |
22 dev-db/sqlite:3 | |
23 !libressl? ( dev-libs/openssl:0[-bindist] ) | |
24 libressl? ( dev-libs/libressl ) | |
25 dev-python/python-application[${PYTHON_USEDEP}] | |
26 media-libs/alsa-lib | |
27 media-libs/libv4l | |
28 media-libs/libvpx | |
29 sys-apps/util-linux | |
30 virtual/ffmpeg | |
31 media-libs/x264 | |
32 " | |
33 RDEPEND="${CDEPEND} | |
34 virtual/python-dnspython[${PYTHON_USEDEP}] | |
35 dev-python/python-cjson[${PYTHON_USEDEP}] | |
36 dev-python/python-dateutil[${PYTHON_USEDEP}] | |
37 dev-python/python-eventlib[${PYTHON_USEDEP}] | |
38 dev-python/greenlet[${PYTHON_USEDEP}] | |
39 dev-python/python-gnutls[${PYTHON_USEDEP}] | |
40 dev-python/lxml[${PYTHON_USEDEP}] | |
41 dev-python/python-msrplib[${PYTHON_USEDEP}] | |
42 dev-python/python-xcaplib[${PYTHON_USEDEP}] | |
43 dev-python/twisted-core[${PYTHON_USEDEP}] | |
44 dev-python/zope-interface[${PYTHON_USEDEP}] | |
45 dev-python/potr[${PYTHON_USEDEP}] | |
46 " | |
47 DEPEND="${CDEPEND} | |
48 dev-python/cython[${PYTHON_USEDEP}] | |
49 virtual/pkgconfig | |
50 " | |
51 | |
52 S="${WORKDIR}/${PN}-release-${PV}" | |
53 | |
54 src_prepare() { | |
55 chmod +x ${S}/deps/pjsip/configure | |
56 chmod +x ${S}/deps/pjsip/aconfigure | |
57 | |
58 epatch "${FILESDIR}/aconfigure.openh264.patch" | |
59 epatch "${FILESDIR}/setup_pjsip.openh264.patch" | |
60 } |