comparison dev-util/bcunit/bcunit-3.0.1.ebuild @ 445:7e560a7c788b

add the necessary ebuilds to make blink work
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 21 Jul 2017 11:00:48 +0200
parents
children
comparison
equal deleted inserted replaced
444:20f79c3e04b5 445:7e560a7c788b
1 # Copyright 1999-2017 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 EAPI=6
5 inherit cmake-utils eutils flag-o-matic multilib-minimal toolchain-funcs
6
7 DESCRIPTION="C Unit Test Framework from Belledonne Comminications"
8 STABLE_REV=fe7c9c5bd32b72542dd96d772b9b5f70adc53117
9 SRC_URI="https://github.com/BelledonneCommunications/bcunit/archive/${STABLE_REV}.tar.gz -> ${P}.tar.gz"
10 HOMEPAGE="https://github.com/BelledonneCommunications/bcunit"
11
12 LICENSE="LGPL-2"
13 SLOT="0"
14 KEYWORDS="~amd64 ~x86"
15 IUSE="ncurses static-libs"
16
17 RDEPEND="ncurses? ( >=sys-libs/ncurses-5.9-r3:0=[${MULTILIB_USEDEP}] )"
18 DEPEND="${RDEPEND}"
19
20 S=${WORKDIR}/${PN}-${STABLE_REV}
21
22 DOCS=( AUTHORS NEWS README ChangeLog )
23
24 multilib_src_configure() {
25 local mycmakeargs=( "-DENABLE_CURSES=$(usex ncurses)" )
26 cmake-utils_src_configure
27 }
28
29 multilib_src_install() {
30 cmake-utils_src_install
31 }