Mercurial > hg > portage
comparison media-libs/mediastreamer/mediastreamer-2.15.1.ebuild @ 445:7e560a7c788b
add the necessary ebuilds to make blink work
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 21 Jul 2017 11:00:48 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
444:20f79c3e04b5 | 445:7e560a7c788b |
---|---|
1 # Copyright 1999-2017 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI=6 | |
5 | |
6 inherit autotools eutils | |
7 | |
8 DESCRIPTION="Mediastreaming library for telephony application" | |
9 HOMEPAGE="http://www.linphone.org/" | |
10 SRC_URI="http://www.linphone.org/releases/sources/${PN}/${P}.tar.gz" | |
11 | |
12 LICENSE="GPL-2" | |
13 SLOT="0/3" | |
14 KEYWORDS="~amd64 ~x86" | |
15 # Many cameras will not work or will crash an application if mediastreamer2 is | |
16 # not built with v4l2 support (taken from configure.ac) | |
17 # TODO: run-time test for ipv6: does it really need ortp[ipv6] ? | |
18 IUSE="+alsa amr bindist coreaudio debug doc examples +filters g726 g729 gsm ilbc | |
19 ipv6 libav ntp-timestamp opengl opus +ortp oss pcap portaudio pulseaudio sdl | |
20 silk +speex static-libs test theora upnp v4l video vpx x264 X" | |
21 | |
22 REQUIRED_USE="|| ( oss alsa portaudio coreaudio pulseaudio ) | |
23 video? ( || ( opengl sdl X ) ) | |
24 theora? ( video ) | |
25 X? ( video ) | |
26 v4l? ( video ) | |
27 opengl? ( video )" | |
28 | |
29 RDEPEND="net-libs/libsrtp:0 | |
30 alsa? ( media-libs/alsa-lib ) | |
31 g726? ( >=media-libs/spandsp-0.0.6_pre1 ) | |
32 gsm? ( media-sound/gsm ) | |
33 opus? ( media-libs/opus ) | |
34 ortp? ( >=net-libs/ortp-1 ) | |
35 pcap? ( sys-libs/libcap ) | |
36 portaudio? ( media-libs/portaudio ) | |
37 pulseaudio? ( media-sound/pulseaudio ) | |
38 speex? ( media-libs/speex media-libs/speexdsp ) | |
39 upnp? ( net-libs/libupnp:* ) | |
40 video? ( | |
41 libav? ( media-video/libav:0/11 ) | |
42 | |
43 opengl? ( media-libs/glew:0 | |
44 virtual/opengl | |
45 x11-libs/libX11 ) | |
46 v4l? ( media-libs/libv4l | |
47 sys-kernel/linux-headers ) | |
48 theora? ( media-libs/libtheora ) | |
49 sdl? ( media-libs/libsdl[video,X] ) | |
50 X? ( x11-libs/libX11 | |
51 x11-libs/libXv ) )" | |
52 DEPEND="${RDEPEND} | |
53 dev-util/intltool | |
54 virtual/pkgconfig | |
55 doc? ( app-doc/doxygen ) | |
56 opengl? ( dev-util/xxdi ) | |
57 test? ( >=dev-util/cunit-2.1_p3[ncurses] ) | |
58 X? ( x11-proto/videoproto )" | |
59 | |
60 PDEPEND="amr? ( !bindist? ( media-plugins/mediastreamer-amr ) ) | |
61 g729? ( !bindist? ( media-plugins/mediastreamer-bcg729 ) ) | |
62 ilbc? ( media-plugins/mediastreamer-ilbc ) | |
63 video? ( x264? ( media-plugins/mediastreamer-x264 ) ) | |
64 silk? ( !bindist? ( media-plugins/mediastreamer-silk ) )" | |
65 | |
66 src_prepare() { | |
67 eapply_user | |
68 | |
69 # variable causes "command not found" warning and is not | |
70 # needed anyway | |
71 sed -i \ | |
72 -e 's/$(ACLOCAL_MACOS_FLAGS)//' \ | |
73 Makefile.am || die | |
74 | |
75 # respect user's CFLAGS | |
76 sed -i \ | |
77 -e "s:-O2::;s: -g::" \ | |
78 configure.ac || die "patching configure.ac failed" | |
79 | |
80 # change default paths | |
81 sed -i \ | |
82 -e "s:\(prefix/share\):\1/${PN}:" \ | |
83 configure.ac || die "patching configure.ac failed" | |
84 | |
85 # fix doc installation dir | |
86 sed -i \ | |
87 -e "s:\$(pkgdocdir):\$(docdir):" \ | |
88 help/Makefile.am || die "patching help/Makefile.am failed" | |
89 | |
90 # fix html installation dir | |
91 sed -i \ | |
92 -e "s:\(doc_htmldir=\).*:\1\$(htmldir):" \ | |
93 help/Makefile.am || die "patching help/Makefile.am failed" | |
94 | |
95 # linux/videodev.h dropped in 2.6.38 | |
96 sed -i \ | |
97 -e 's:linux/videodev.h ::' \ | |
98 configure.ac || die | |
99 | |
100 # break check for conflicts with polarssl (emdedtls is used instead anyway) | |
101 sed -i \ | |
102 -e 's:sha1_update:sha1_update_XXX:' \ | |
103 configure.ac || die | |
104 | |
105 epatch \ | |
106 "${FILESDIR}/${PN}-underlinking.patch" \ | |
107 "${FILESDIR}/${PN}-xxd.patch" | |
108 | |
109 eautoreconf | |
110 } | |
111 | |
112 src_configure() { | |
113 local myeconfargs=( | |
114 --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html | |
115 --datadir="${EPREFIX}"/usr/share/${PN} | |
116 # arts is deprecated | |
117 --disable-artsc | |
118 # don't want -Werror | |
119 --disable-strict | |
120 --disable-libv4l1 | |
121 # don't use bundled libs | |
122 --enable-external-ortp | |
123 $(use_enable alsa) | |
124 $(use_enable pulseaudio) | |
125 $(use_enable coreaudio macsnd) | |
126 $(use_enable debug) | |
127 $(use_enable filters) | |
128 $(use_enable g726 spandsp) | |
129 $(use_enable gsm) | |
130 $(use_enable ntp-timestamp) | |
131 $(use_enable opengl glx) | |
132 $(use_enable opus) | |
133 $(use_enable ortp) | |
134 $(use_enable oss) | |
135 $(use_enable pcap) | |
136 $(use_enable portaudio) | |
137 $(use_enable speex) | |
138 $(use_enable static-libs static) | |
139 $(use_enable theora) | |
140 $(use_enable upnp) | |
141 $(use_enable video) | |
142 $(use_enable vpx vp8) | |
143 $(use_enable v4l) | |
144 $(use_enable v4l libv4l2) | |
145 $(use_enable sdl) | |
146 $(use_enable X x11) | |
147 $(use_enable X xv) | |
148 | |
149 $(use doc || echo ac_cv_path_DOXYGEN=false) | |
150 ) | |
151 | |
152 # Mac OS X Audio Queue is an audio recording facility, available on | |
153 # 10.5 (Leopard, Darwin9) and onward | |
154 if use coreaudio && [[ ${CHOST} == *-darwin* && ${CHOST##*-darwin} -ge 9 ]] | |
155 then | |
156 myeconfargs+=( --enable-macaqsnd ) | |
157 else | |
158 myeconfargs+=( --disable-macaqsnd ) | |
159 fi | |
160 | |
161 econf "${myeconfargs[@]}" | |
162 } | |
163 | |
164 src_test() { | |
165 default | |
166 cd tester || die | |
167 ./mediastreamer2_tester || die | |
168 } | |
169 | |
170 src_install() { | |
171 default | |
172 prune_libtool_files | |
173 | |
174 if use examples; then | |
175 insinto /usr/share/doc/${PF}/examples | |
176 doins tester/*.c | |
177 fi | |
178 } |