Mercurial > hg > portage
comparison net-voip/belle-sip/belle-sip-1.6.1.ebuild @ 445:7e560a7c788b
add the necessary ebuilds to make blink work
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 21 Jul 2017 11:00:48 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
444:20f79c3e04b5 | 445:7e560a7c788b |
---|---|
1 # Copyright 1999-2017 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI=6 | |
5 | |
6 inherit autotools eutils flag-o-matic | |
7 | |
8 DESCRIPTION="C object oriented SIP Stack." | |
9 HOMEPAGE="http://www.linphone.org/technical-corner/belle-sip/overview" | |
10 SRC_URI="http://www.linphone.org/releases/sources/${PN}/${P}.tar.gz" | |
11 | |
12 LICENSE="GPL-2" | |
13 KEYWORDS="~amd64 ~x86" | |
14 | |
15 SLOT="0" | |
16 | |
17 IUSE="debug examples test +tls -tunnel +zlib" | |
18 REQUIRED_USE="" | |
19 | |
20 DEPEND="${RDEPEND} | |
21 dev-java/antlr:3 | |
22 dev-libs/antlr-c | |
23 net-libs/bctoolbox | |
24 dev-util/intltool | |
25 sys-devel/libtool | |
26 virtual/pkgconfig | |
27 test? ( >=dev-util/cunit-2.1_p3[ncurses] )" | |
28 | |
29 src_prepare() { | |
30 default | |
31 sed -i -e 's,-Werror,,' configure.ac || die | |
32 eautoreconf | |
33 } | |
34 | |
35 src_configure() { | |
36 local myeconfargs=( | |
37 $(use_enable debug) | |
38 $(use_enable tls) | |
39 $(use_enable tunnel) | |
40 $(use_enable test tests) | |
41 $(use_enable zlib) | |
42 ) | |
43 | |
44 econf "${myeconfargs[@]}" | |
45 } | |
46 | |
47 src_test() { | |
48 default | |
49 test -d tester || die | |
50 emake -C tester test | |
51 } | |
52 | |
53 src_install() { | |
54 default | |
55 prune_libtool_files | |
56 | |
57 if use examples; then | |
58 insinto /usr/share/doc/${PF}/examples | |
59 doins tester/*.c | |
60 fi | |
61 } |