Mercurial > hg > portage
comparison net-voip/blink/blink-3.0.3.ebuild @ 445:7e560a7c788b
add the necessary ebuilds to make blink work
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 21 Jul 2017 11:00:48 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
444:20f79c3e04b5 | 445:7e560a7c788b |
---|---|
1 # Copyright 1999-2017 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI="6" | |
5 | |
6 PYTHON_COMPAT=( python2_7 ) | |
7 DISTUTILS_SINGLE_IMPL=1 | |
8 | |
9 inherit eutils gnome2-utils distutils-r1 | |
10 | |
11 DESCRIPTION="A state of the art, easy to use SIP client" | |
12 HOMEPAGE="http://iCanBlink.com" | |
13 SRC_URI="https://github.com/AGProjects/${PN}-qt/archive/release-${PV}.tar.gz" | |
14 | |
15 S="${WORKDIR}/${PN}-qt-release-${PV}" | |
16 | |
17 LICENSE="GPL-3" | |
18 SLOT="0" | |
19 IUSE="" | |
20 | |
21 KEYWORDS="~amd64 ~x86" | |
22 | |
23 CDEPEND="net-libs/libvncserver" | |
24 RDEPEND="${CDEPEND} | |
25 dev-python/python-application[${PYTHON_USEDEP}] | |
26 dev-python/python-cjson[${PYTHON_USEDEP}] | |
27 dev-python/python-eventlib[${PYTHON_USEDEP}] | |
28 dev-python/PyQt5[webkit,${PYTHON_USEDEP}] | |
29 dev-python/twisted-core[${PYTHON_USEDEP}] | |
30 >=dev-python/python-sipsimple-3.1.0[${PYTHON_USEDEP}] | |
31 dev-python/zope-interface[${PYTHON_USEDEP}] | |
32 dev-python/google-api-python-client[${PYTHON_USEDEP}] | |
33 dev-python/python-dateutil[${PYTHON_USEDEP}] | |
34 dev-python/gmpy:2[${PYTHON_USEDEP}] | |
35 >=dev-python/python-application-2.0.0[${PYTHON_USEDEP}] | |
36 >=dev-python/python-otr-1.2.0[${PYTHON_USEDEP}] | |
37 dev-python/python-gnutls[${PYTHON_USEDEP}] | |
38 " | |
39 DEPEND="${CDEPEND} | |
40 dev-python/cython[${PYTHON_USEDEP}]" | |
41 | |
42 src_compile() { | |
43 python setup.py build_ext | |
44 } | |
45 | |
46 src_install() { | |
47 python setup.py install --home "${D}" --install-purelib="${D}"usr/lib64/python2.7/site-packages --install-platlib="${D}"usr/lib64/python2.7/site-packages --install-scripts="${D}"/usr/bin --install-data="${D}"usr | |
48 | |
49 newicon -s 48 resources/icons/blink48.png blink.png | |
50 newicon -s 64 resources/icons/blink64.png blink.png | |
51 doicon -s 512 resources/icons/blink.png | |
52 | |
53 make_desktop_entry ${PN} Blink | |
54 } | |
55 | |
56 pkg_preinst() { | |
57 gnome2_icon_savelist | |
58 } | |
59 | |
60 pkg_postinst() { | |
61 gnome2_icon_cache_update | |
62 } | |
63 | |
64 pkg_postrm() { | |
65 gnome2_icon_cache_update | |
66 } |