Mercurial > hg > portage
comparison app-arch/pigz/pigz-2.1.4.ebuild @ 116:8297e50e2a90
pigz is a multithreaded gzip
author | holger@hoho.dyndns.org |
---|---|
date | Sat, 07 Mar 2009 08:15:02 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
115:0af76f5d37e9 | 116:8297e50e2a90 |
---|---|
1 # Copyright 1999-2008 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: $ | |
4 | |
5 inherit eutils flag-o-matic | |
6 | |
7 DESCRIPTION="Standard GNU compressor" | |
8 HOMEPAGE="http://www.zlib.net/pigz/" | |
9 SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz" | |
10 | |
11 LICENSE="GPL-2" | |
12 SLOT="0" | |
13 KEYWORDS="~x86" | |
14 | |
15 RDEPEND="" | |
16 DEPEND="${RDEPEND} | |
17 sys-libs/zlib" | |
18 | |
19 src_unpack() { | |
20 unpack ${A} | |
21 cd "${S}" | |
22 } | |
23 | |
24 src_compile() { | |
25 emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die | |
26 } | |
27 | |
28 src_install() { | |
29 dobin pigz || die | |
30 } |