Mercurial > hg > portage
comparison sys-block/noflushd/noflushd-2.8.ebuild @ 280:8679a9a2a216
updated ebuild for latest noflush-2.8
author | holger |
---|---|
date | Fri, 01 Apr 2011 17:25:41 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
279:a5d43ca434f7 | 280:8679a9a2a216 |
---|---|
1 # Copyright 1999-2009 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/sys-block/noflushd/noflushd-2.7.5.ebuild,v 1.2 2009/04/11 15:18:15 vapier Exp $ | |
4 | |
5 DESCRIPTION="A daemon to spin down your disks and force accesses to be cached" | |
6 HOMEPAGE="http://noflushd.sourceforge.net/" | |
7 SRC_URI="mirror://sourceforge/noflushd/${PN}-${PV}.tar.gz" | |
8 | |
9 LICENSE="GPL-2" | |
10 SLOT="0" | |
11 KEYWORDS="~amd64 ~ppc ~x86" | |
12 IUSE="" | |
13 | |
14 src_compile() { | |
15 econf \ | |
16 --with-docdir=/usr/share/doc/${PF} \ | |
17 --with-initdir=/etc/init.d | |
18 emake || die | |
19 } | |
20 | |
21 src_install() { | |
22 emake install DESTDIR="${D}" || die | |
23 dodoc NEWS | |
24 prepalldocs | |
25 | |
26 newinitd "${FILESDIR}"/noflushd.rc6 noflushd | |
27 newconfd "${FILESDIR}"/noflushd.confd noflushd | |
28 } | |
29 | |
30 pkg_postinst() { | |
31 ewarn "noflushd works with IDE devices only." | |
32 ewarn "It has possible problems with reiserfs, too." | |
33 } |