Mercurial > hg > portage
comparison dev-java/ant-bin/ant-bin-1.8.1.ebuild @ 238:86a0cec24d06
Automated merge with http://hoho.dyndns.org/hg/portage
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 11 Aug 2010 04:08:09 +0200 |
parents | ea975b812fa2 |
children |
comparison
equal
deleted
inserted
replaced
237:2864788b37cf | 238:86a0cec24d06 |
---|---|
1 | |
2 inherit java-pkg-2 | |
3 | |
4 DESCRIPTION="Java-based build tool similar to 'make' that uses XML configuration files." | |
5 HOMEPAGE="http://ant.apache.org/" | |
6 | |
7 MY_P="apache-ant-1.8.1" | |
8 SRC_URI="mirror://apache/ant/binaries/${MY_P}-bin.tar.gz" | |
9 LICENSE="Apache-2.0" | |
10 KEYWORDS="~amd64 ~ppc ~x86" | |
11 | |
12 SLOT="0" | |
13 RDEPEND=">=virtual/jdk-1.5" | |
14 IUSE="" | |
15 | |
16 S="${WORKDIR}/${MY_P}" | |
17 ANT_SHARE="/usr/share/${PN}" | |
18 | |
19 src_unpack() { | |
20 unpack ${A} | |
21 | |
22 rm -v "${S}"/bin/*.bat || die | |
23 rm -v "${S}"/bin/*.cmd || die | |
24 } | |
25 | |
26 src_install() { | |
27 dodir "${ANT_SHARE}" | |
28 cp -Rp bin etc lib fetch.xml get-m2.xml "${D}/${ANT_SHARE}" || die "failed to copy" | |
29 | |
30 java-pkg_regjar "${D}/${ANT_SHARE}"/lib/*.jar | |
31 | |
32 dodoc INSTALL KEYS LICENSE NOTICE README WHATSNEW || die | |
33 | |
34 dodir /usr/bin | |
35 dosym "${ANT_SHARE}/bin/ant" /usr/bin/ant | |
36 } |