Mercurial > hg > portage
comparison www-apps/redaxo/redaxo-4.2.1.ebuild @ 238:86a0cec24d06
Automated merge with http://hoho.dyndns.org/hg/portage
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 11 Aug 2010 04:08:09 +0200 |
parents | 0696f0fa8ee4 |
children |
comparison
equal
deleted
inserted
replaced
237:2864788b37cf | 238:86a0cec24d06 |
---|---|
1 | |
2 EAPI=2 | |
3 inherit webapp depend.php versionator | |
4 | |
5 DESCRIPTION="PHP-powered CMS application." | |
6 HOMEPAGE="http://www.redaxo.de/" | |
7 | |
8 # translate redaxo-0.0.0 to redaxo0_0_0 | |
9 MY_PV=$(replace_all_version_separators '_') | |
10 MY_P=${PN}${MY_PV} | |
11 SRC_URI="http://www.redaxo.de/files/${MY_P}.zip" | |
12 | |
13 LICENSE="GPL" | |
14 KEYWORDS="~amd64 ~x86" | |
15 DEPEND="app-arch/unzip" | |
16 RDEPEND="virtual/httpd-cgi" | |
17 | |
18 need_php_httpd | |
19 | |
20 pkg_setup() { | |
21 webapp_pkg_setup | |
22 | |
23 if ! PHPCHECKNODIE="yes" require_php_with_any_use mysql ; then | |
24 eerror | |
25 eerror "${PHP_PKG} needs to be reinstalled with the mysql USE flag enabled." | |
26 die "Reinstall ${PHP_PKG} with the above-stated USE flags." | |
27 fi | |
28 } | |
29 | |
30 src_unpack() { | |
31 unpack ${A} | |
32 | |
33 # clean up some cruft that comes as part of the install package | |
34 cd ${WORKDIR}/${MY_P} | |
35 find . -name .DS_Store -exec rm {} \; | |
36 remove_if_exists _lastchanges.txt | |
37 } | |
38 | |
39 src_install() { | |
40 webapp_src_preinst | |
41 | |
42 einfo "Installing application files." | |
43 cd ${MY_P} | |
44 cp -r . "${D}"${MY_HTDOCSDIR} | |
45 | |
46 # .htaccess, index.php and the redaxo dir are part of the distro | |
47 local SERVEROWNED="index.php files files/_readme.txt files/addons \ | |
48 redaxo redaxo/include/clang.inc.php redaxo/include/plugins.inc.php \ | |
49 redaxo/include/addons.inc.php redaxo/include/master.inc.php \ | |
50 redaxo/include/generated redaxo/include/generated/* \ | |
51 redaxo/include/addons/* redaxo/include/addons/import_export/backup \ | |
52 redaxo/include/addons/image_resize/config.inc.php" | |
53 for SFILES in ${SERVEROWNED}; do | |
54 webapp_serverowned ${MY_HTDOCSDIR}/${SFILES} | |
55 done | |
56 | |
57 webapp_src_install | |
58 } | |
59 | |
60 webapp_pkg_postinst() { | |
61 einfo "This ebuild does not perform any autoinstall of the package" | |
62 einfo "" | |
63 einfo "This allows you to install redaxo directly into the top of" | |
64 einfo "your document root using:" | |
65 einfo "webapp-config -I -h localhost -u root redaxo ${PV}" | |
66 einfo "" | |
67 } | |
68 | |
69 function remove_if_exists() { | |
70 if [ -f $1 ]; then | |
71 rm $1 | |
72 fi | |
73 } |