Mercurial > hg > portage
comparison dev-db/postgresql-docs/postgresql-docs-8.4.1.ebuild @ 159:9014d136897e
update postgres to 8.4.1
author | holger |
---|---|
date | Wed, 09 Sep 2009 17:22:48 +0200 |
parents | dev-db/postgresql-docs/postgresql-docs-8.4.0.ebuild@fb0267e87240 |
children | 7ce3014adf4b |
comparison
equal
deleted
inserted
replaced
158:cc901061d3c6 | 159:9014d136897e |
---|---|
1 # Copyright 1999-2009 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.3.7.ebuild,v 1.4 2009/06/05 22:49:22 beandog Exp $ | |
4 | |
5 inherit versionator | |
6 | |
7 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd" | |
8 | |
9 # Nothing to test here per 232157 | |
10 RESTRICT="test" | |
11 | |
12 DESCRIPTION="PostgreSQL documentation" | |
13 HOMEPAGE="http://www.postgresql.org/" | |
14 SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2" | |
15 LICENSE="POSTGRESQL" | |
16 SLOT="$(get_version_component_range 1-2)" | |
17 IUSE="" | |
18 | |
19 DEPEND="" | |
20 RDEPEND="" | |
21 RESTRICT="test" | |
22 | |
23 S="${WORKDIR}/postgresql-${PV}" | |
24 | |
25 src_compile() { | |
26 : | |
27 } | |
28 | |
29 src_install() { | |
30 dodir /usr/share/doc/${PF}/html | |
31 tar -zxf "${S}/doc/postgres.tar.gz" -C "${D}/usr/share/doc/${PF}/html" | |
32 cd "${S}/doc" | |
33 dodoc TODO | |
34 docinto FAQ_html | |
35 dodoc src/FAQ/* | |
36 | |
37 dodir /etc/eselect/postgresql/slots/${SLOT} | |
38 { | |
39 echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" | |
40 } >"${D}/etc/eselect/postgresql/slots/${SLOT}/docs" | |
41 } |