comparison net-misc/rabbitmq-server/rabbitmq-server-1.4.0.ebuild @ 58:92f35dfbf2b8

cleanup template comments
author holger@hoho.dyndns.org
date Wed, 13 Aug 2008 20:56:04 +0200
parents 11f27faa9896
children 6a65c52cb465
comparison
equal deleted inserted replaced
56:baac049cd305 58:92f35dfbf2b8
1 # Copyright 1999-2008 Gentoo Foundation 1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2 2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $ 3 # $Header: $
4 4
5 # NOTE: The comments in this file are for instruction and documentation. 5 inherit eutils
6 # They're not meant to appear with your final, production ebuild. Please
7 # remember to remove them before submitting or committing your ebuild. That
8 # doesn't mean you can't add your own comments though.
9 6
10 # The 'Header' on the third line should just be left alone. When your ebuild
11 # will be committed to cvs, the details on that line will be automatically
12 # generated to contain the correct data.
13
14 # The EAPI variable tells the ebuild format in use.
15 # Defaults to 0 if not specified. The current PMS draft contains details on
16 # a proposed EAPI=0 definition but is not finalized yet.
17 # Eclasses will test for this variable if they need to use EAPI > 0 features.
18 # Ebuilds should not define EAPI > 0 unless they absolutely need to use
19 # features added in that version.
20 #EAPI=0
21
22 # inherit lists eclasses to inherit functions from. Almost all ebuilds should
23 # inherit eutils, as a large amount of important functionality has been
24 # moved there. For example, the $(get_libdir) mentioned below wont work
25 # without the following line:
26 inherit eutils
27 # A well-used example of an eclass function that needs eutils is epatch. If
28 # your source needs patches applied, it's suggested to put your patch in the
29 # 'files' directory and use:
30 #
31 # epatch ${FILESDIR}/patch-name-here
32 #
33 # eclasses tend to list descriptions of how to use their functions properly.
34 # take a look at /usr/portage/eclasses/ for more examples.
35
36 # Short one-line description of this package.
37 DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang." 7 DESCRIPTION="RabbitMQ is a high-performance AMQP-compliant message broker written in Erlang."
38 8 HOMEPAGE="http://www.rabbitmq.com/"
39 # Homepage, not used by Portage directly but handy for developer reference
40 HOMEPAGE="http://www.rabbitmq.com/"
41
42 # Point to any required sources; these will be automatically downloaded by
43 # Portage.
44 SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz" 9 SRC_URI="http://www.rabbitmq.com/releases/rabbitmq-server/v${PV}/rabbitmq-server-generic-unix-${PV}.tar.gz"
45
46 # License of the package. This must match the name of file(s) in
47 # /usr/portage/licenses/. For complex license combination see the developer
48 # docs on gentoo.org for details.
49 LICENSE="MPL" 10 LICENSE="MPL"
50 11 SLOT="0"
51 # The SLOT variable is used to tell Portage if it's OK to keep multiple 12 KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
52 # versions of the same package installed at the same time. For example,
53 # if we have a libfoo-1.2.2 and libfoo-1.3.2 (which is not compatible
54 # with 1.2.2), it would be optimal to instruct Portage to not remove
55 # libfoo-1.2.2 if we decide to upgrade to libfoo-1.3.2. To do this,
56 # we specify SLOT="1.2" in libfoo-1.2.2 and SLOT="1.3" in libfoo-1.3.2.
57 # emerge clean understands SLOTs, and will keep the most recent version
58 # of each SLOT and remove everything else.
59 # Note that normal applications should use SLOT="0" if possible, since
60 # there should only be exactly one version installed at a time.
61 # DO NOT USE SLOT=""! This tells Portage to disable SLOTs for this package.
62 SLOT="0"
63
64 # Using KEYWORDS, we can record masking information *inside* an ebuild
65 # instead of relying on an external package.mask file. Right now, you should
66 # set the KEYWORDS variable for every ebuild so that it contains the names of
67 # all the architectures with which the ebuild works. All of the official
68 # architectures can be found in the keywords.desc file which is in
69 # /usr/portage/profiles/. Usually you should just set this to "~x86". The ~
70 # in front of the architecture indicates that the package is new and should be
71 # considered unstable until testing proves its stability. So, if you've
72 # confirmed that your ebuild works on x86 and ppc, you'd specify:
73 # KEYWORDS="~x86 ~ppc"
74 # Once packages go stable, the ~ prefix is removed.
75 # For binary packages, use -* and then list the archs the bin package
76 # exists for. If the package was for an x86 binary package, then
77 # KEYWORDS would be set like this: KEYWORDS="-* x86"
78 # DO NOT USE KEYWORDS="*". This is deprecated and only for backward
79 # compatibility reasons.
80 KEYWORDS="~x86"
81
82 # Comprehensive list of any and all USE flags leveraged in the ebuild,
83 # with the exception of any ARCH specific flags, i.e. "ppc", "sparc",
84 # "x86" and "alpha". This is a required variable. If the ebuild doesn't
85 # use any USE flags, set to "".
86 IUSE="" 13 IUSE=""
87 14
88 # A space delimited list of portage features to restrict. man 5 ebuild 15 # HH: is RDEPEND-only sufficient for a binary package?
89 # for details. Usually not needed.
90 #RESTRICT="strip"
91
92 # Build-time dependencies, such as
93 # ssl? ( >=dev-libs/openssl-0.9.6b )
94 # >=dev-lang/perl-5.6.1-r1
95 # It is advisable to use the >= syntax show above, to reflect what you
96 # had installed on your system when you tested the package. Then
97 # other users hopefully won't be caught without the right version of
98 # a dependency.
99 DEPEND="dev-lang/erlang" 16 DEPEND="dev-lang/erlang"
100
101 # Run-time dependencies. Must be defined to whatever this depends on to run.
102 # The below is valid if the same run-time depends are required to compile.
103 RDEPEND="${DEPEND}" 17 RDEPEND="${DEPEND}"
104 18
105 # Source directory; the dir where the sources can be found (automatically 19 # Source directory; the dir where the sources can be found (automatically
106 # unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P} 20 # unpacked) inside ${WORKDIR}. The default value for S is ${WORKDIR}/${P}
107 # If you don't need to change it, leave the S= line out of the ebuild 21 # If you don't need to change it, leave the S= line out of the ebuild