Mercurial > hg > portage
comparison net-im/skype/skype-2.1.0.47.ebuild @ 145:93b38fc95d26
ebuild for new Skype beta version
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Wed, 02 Sep 2009 02:53:28 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
144:b96a69963456 | 145:93b38fc95d26 |
---|---|
1 # Copyright 1999-2009 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/net-im/skype/skype-2.0.0.72.ebuild,v 1.3 2009/04/14 09:38:40 armin76 Exp $ | |
4 | |
5 EAPI=2 | |
6 | |
7 inherit eutils qt4 pax-utils | |
8 | |
9 DESCRIPTION="A P2P-VoiceIP client." | |
10 HOMEPAGE="http://www.skype.com/" | |
11 | |
12 SFILENAME=${PN}_static-${PV}.tar.bz2 | |
13 DFILENAME=${P}.tar.bz2 | |
14 SRC_URI="!qt-static? ( http://download.skype.com/linux/${DFILENAME} ) | |
15 qt-static? ( http://download.skype.com/linux/${SFILENAME} )" | |
16 | |
17 LICENSE="skype-eula" | |
18 SLOT="0" | |
19 KEYWORDS="amd64 x86" | |
20 IUSE="qt-static" | |
21 RESTRICT="mirror strip" | |
22 | |
23 DEPEND="amd64? ( >=app-emulation/emul-linux-x86-xlibs-1.2 | |
24 >=app-emulation/emul-linux-x86-baselibs-2.1.1 | |
25 >=app-emulation/emul-linux-x86-soundlibs-2.4 | |
26 app-emulation/emul-linux-x86-compat ) | |
27 x86? ( >=sys-libs/glibc-2.4 | |
28 >=media-libs/alsa-lib-1.0.11 | |
29 x11-libs/libXScrnSaver | |
30 x11-libs/libXv | |
31 qt-static? ( media-libs/fontconfig | |
32 media-libs/freetype | |
33 x11-libs/libICE | |
34 x11-libs/libSM | |
35 x11-libs/libXcursor | |
36 x11-libs/libXext | |
37 x11-libs/libXfixes | |
38 x11-libs/libXi | |
39 x11-libs/libXinerama | |
40 x11-libs/libXrandr | |
41 x11-libs/libXrender | |
42 x11-libs/libX11 ) | |
43 !qt-static? ( x11-libs/qt-core:4 | |
44 x11-libs/qt-gui:4[accessibility,dbus] | |
45 x11-libs/qt-dbus:4 | |
46 x11-libs/libX11 | |
47 x11-libs/libXau | |
48 x11-libs/libXdmcp ) )" | |
49 RDEPEND="${DEPEND}" | |
50 | |
51 QA_EXECSTACK="opt/skype/skype" | |
52 | |
53 use qt-static && S="${WORKDIR}/${PN}_static-${PV}" | |
54 | |
55 src_install() { | |
56 exeinto /opt/${PN} | |
57 doexe skype | |
58 fowners root:audio /opt/skype/skype | |
59 make_wrapper skype /opt/${PN}/skype /opt/${PN} /opt/${PN} /usr/bin | |
60 | |
61 insinto /opt/${PN}/sounds | |
62 doins sounds/*.wav | |
63 | |
64 if ! use qt-static ; then | |
65 insinto /etc/dbus-1/system.d | |
66 newins "${FILESDIR}"/skype.debus.config skype.conf | |
67 fi | |
68 | |
69 insinto /opt/${PN}/lang | |
70 # | |
71 #There have been some issues were lang is not updated from the .ts files | |
72 #but if we have qt we can rebuild it | |
73 # | |
74 if ! use qt-static ; then | |
75 lrelease lang/*.ts | |
76 fi | |
77 | |
78 doins lang/*.qm | |
79 | |
80 insinto /opt/${PN}/avatars | |
81 doins avatars/*.png | |
82 | |
83 insinto /opt/${PN} | |
84 for X in 16 32 48 | |
85 do | |
86 insinto /usr/share/icons/hicolor/${X}x${X}/apps | |
87 newins "${S}"/icons/SkypeBlue_${X}x${X}.png ${PN}.png | |
88 done | |
89 | |
90 dodoc README | |
91 | |
92 # insinto /usr/share/applications/ | |
93 # doins skype.desktop | |
94 make_desktop_entry ${PN} "Skype VoIP" ${PN} "Network;InstantMessaging;Telephony" | |
95 | |
96 #Fix for no sound notifications | |
97 dosym /opt/${PN} /usr/share/${PN} | |
98 | |
99 # TODO: Optional configuration of callto:// in KDE, Mozilla and friends | |
100 # doexe skype-callto-handler | |
101 } |