comparison dev-java/maven-bin/maven-bin-3.0.0.ebuild @ 246:97d85f6a8c32

oops, this was missing
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 04 Oct 2010 18:26:45 +0200
parents
children 2dcbfb21d30b
comparison
equal deleted inserted replaced
245:0939a205e18f 246:97d85f6a8c32
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/dev-java/maven-bin/maven-bin-2.2.1.ebuild,v 1.3 2010/04/26 11:05:56 phajdan.jr Exp $
4
5 inherit java-pkg-2
6 inherit versionator
7
8 MY_P="apache-maven-3.0"
9
10 DESCRIPTION="Project Management and Comprehension Tool for Java"
11 SRC_URI="mirror://apache/maven/binaries/${MY_P}-bin.tar.gz"
12 HOMEPAGE="http://maven.apache.org/"
13 LICENSE="Apache-2.0"
14 SLOT="3.0"
15 KEYWORDS="~amd64 ~ppc ~x86"
16
17 RDEPEND=">=virtual/jdk-1.5
18 app-admin/eselect-maven"
19
20 IUSE=""
21
22 S="${WORKDIR}/${MY_P}"
23
24 MAVEN=${PN}-${SLOT}
25 MAVEN_SHARE="/usr/share/${MAVEN}"
26
27 src_unpack() {
28 unpack ${A}
29
30 rm -v "${S}"/bin/*.bat || die
31 }
32
33 # TODO we should use jars from packages, instead of what is bundled
34 src_install() {
35 dodir "${MAVEN_SHARE}"
36 cp -Rp bin boot conf lib "${D}/${MAVEN_SHARE}" || die "failed to copy"
37
38 java-pkg_regjar "${D}/${MAVEN_SHARE}"/lib/*.jar
39
40 dodoc NOTICE.txt README.txt || die
41
42 dodir /usr/bin
43 dosym "${MAVEN_SHARE}/bin/mvn" /usr/bin/mvn-${SLOT}
44 }