comparison app-crypt/veracrypt/veracrypt-1.13.ebuild @ 397:a13344a4a7bb

add an ebuild for the latest veracrypt release
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 31 Aug 2015 05:48:32 +0200
parents
children 442474170ed1
comparison
equal deleted inserted replaced
396:af9fcfc5c007 397:a13344a4a7bb
1 # Copyright 1999-2015 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 inherit unpacker
8
9 DESCRIPTION="VeraCrypt is a free disk encryption software based on TrueCrypt"
10 HOMEPAGE="https://veracrypt.codeplex.com"
11 SRC_URI="https://github.com/veracrypt/VeraCrypt/archive/VeraCrypt_1.13.tar.gz -> ${P}.tar.gz"
12
13 LICENSE="truecrypt-3.0"
14 SLOT="0"
15 KEYWORDS="~amd64"
16 IUSE=""
17
18 RESTRICT="mirror"
19
20 DEPEND="
21 sys-devel/make
22 dev-lang/nasm
23 app-arch/makeself
24 sys-fs/fuse
25 x11-libs/wxGTK:3.0
26 "
27
28 RDEPEND="${DEPEND}"
29
30 S=${WORKDIR}
31
32 src_unpack() {
33 unpack ${A} || die "Could not unpack!"
34 mv ${WORKDIR}/* ${WORKDIR}/${PN} || die "Could not move directory!"
35 return
36 }
37
38 src_compile() {
39 cd ${WORKDIR}/${PN}/src
40 make || die "Could not make VeraCrypt!"
41 return
42 }
43
44 src_install() {
45 exeinto /usr/bin
46 doexe ${WORKDIR}/${PN}/src/Main/veracrypt || die "Could not install veracrypt executable!"
47 insinto /usr/share/pixmaps
48 doins "${FILESDIR}"/veracrypt.png || die "Could not copy veracrypt.png"
49 return
50 }
51
52 pkg_postinst() {
53 xdg-desktop-menu install --novendor "${FILESDIR}"/veracrypt.desktop || die "Could not register a menu item!"
54 return
55 }
56
57 pkg_postrm() {
58 xdg-desktop-menu uninstall "${FILESDIR}"/veracrypt.desktop || die "Could not de-register a menu item!"
59 return
60 }