Mercurial > hg > portage
comparison www-apps/egroupware/egroupware-1.8.002.20111011.ebuild @ 284:a96ea427e9a0
ebuild for the latest egroupware including dependencies
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Sat, 05 Nov 2011 03:27:42 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
283:18e9c4ed5f1f | 284:a96ea427e9a0 |
---|---|
1 # Copyright 1999-2010 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: $ | |
4 | |
5 ## | |
6 # based on ebuild from bug #284536, depending on dev-php/PEAR-XML_Feed_Parser from #258604 | |
7 ## | |
8 | |
9 EAPI="2" | |
10 | |
11 inherit eutils versionator webapp depend.php | |
12 | |
13 MY_PN=eGroupware | |
14 MY_PV=$(get_version_component_range 1-3) | |
15 MY_P=$(get_version_component_range 4-) | |
16 #MY_P="${MY_P/p/}" | |
17 | |
18 DESCRIPTION="Web-based GroupWare suite" | |
19 HOMEPAGE="http://www.egroupware.org/" | |
20 SRC_URI="mirror://sourceforge/${PN}/${MY_PN}-${MY_PV}.${MY_P}.tar.bz2 | |
21 mirror://sourceforge/${PN}/${MY_PN}-egw-pear-${MY_PV}.${MY_P}.tar.bz2 | |
22 phpfreechat? ( mirror://sourceforge/${PN}/${MY_PN}-phpfreechat-${MY_PV}.${MY_P}.tar.bz2 ) | |
23 gallery? ( mirror://sourceforge/${PN}/${MY_PN}-gallery-${MY_PV}.${MY_P}.tar.bz2 )" | |
24 | |
25 LICENSE="GPL-2" | |
26 KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86" | |
27 IUSE="ldap mssql mysql postgres gallery phpfreechat jpgraph" | |
28 | |
29 #hint: sqlite needed for calendar | |
30 RDEPEND=" | |
31 dev-lang/php[ctype,imap,ldap?,mssql?,mysql?,pdo,postgres?,session,sqlite3,unicode] | |
32 || ( | |
33 dev-lang/php[gd] | |
34 dev-lang/php[gd-external] | |
35 ) | |
36 dev-php/PEAR-Auth_SASL | |
37 dev-php/PEAR-PEAR | |
38 dev-php/PEAR-XML_Feed_Parser | |
39 virtual/cron | |
40 jpgraph? ( dev-php/jpgraph ) | |
41 " | |
42 # >dev-php5/jpgraph-1.13 | |
43 | |
44 | |
45 need_httpd_cgi | |
46 need_php_httpd | |
47 | |
48 S=${WORKDIR}/${PN} | |
49 | |
50 src_prepare() { | |
51 esvn_clean | |
52 | |
53 if use jpgraph; then | |
54 einfo "Fixing jpgraph location" | |
55 MY_JPGRAPH_VERSION="$(best_version dev-php5/jpgraph)" | |
56 MY_JPGRAPH_VERSION="${MY_JPGRAPH_VERSION/'dev-php5/jpgraph-'/}" | |
57 sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph.php'|'/usr/share/php5/jpgraph/jpgraph.php'|" \ | |
58 projectmanager/inc/class.projectmanager_ganttchart.inc.php || die | |
59 sed -i "s|EGW_SERVER_ROOT . '/../jpgraph/src/jpgraph_gantt.php'|'/usr/share/php5/jpgraph/jpgraph_gantt.php'|" \ | |
60 projectmanager/inc/class.projectmanager_ganttchart.inc.php || die | |
61 sed -i "s|$jpgraph_path .= SEP.'jpgraph';|$jpgraph_path = dirname('/usr/share/php5/jpgraph/jpgraph.php');|" \ | |
62 setup/check_install.php || die | |
63 sed -i "s|'unknown';|'${MY_JPGRAPH_VERSION}';\n \$available = version_compare(\$version,\$min_version,'>=');|" \ | |
64 setup/check_install.php || die | |
65 fi | |
66 } | |
67 | |
68 src_install() { | |
69 webapp_src_preinst | |
70 insinto "${MY_HTDOCSDIR}" | |
71 doins -r . | |
72 webapp_serverowned "${MY_HTDOCSDIR}/phpgwapi/images" | |
73 webapp_postinst_txt en "${FILESDIR}/postinstall-en-1.2.txt" | |
74 webapp_src_install | |
75 } | |
76 | |
77 pkg_postinst() { | |
78 if use ldap; then | |
79 elog "If you are using LDAP contacts/addressbook, please read the upgrade instructions at" | |
80 elog "http://www.egroupware.org/index.php?page_name=wiki&wikipage=ManualSetupUpdate" | |
81 elog "before running the egroupware setup" | |
82 fi | |
83 webapp_pkg_postinst | |
84 } |