Mercurial > hg > portage
comparison dev-db/pgpool-II/pgpool-II-2.2.5.ebuild @ 166:aec49d51a27b
update pgpool-II to 2.2.5 (minor ebuild fix)
author | holger |
---|---|
date | Mon, 05 Oct 2009 18:59:50 +0200 |
parents | dev-db/pgpool-II/pgpool-II-2.2.4.ebuild@cc901061d3c6 |
children |
comparison
equal
deleted
inserted
replaced
165:331dc8ae6ba4 | 166:aec49d51a27b |
---|---|
1 # Copyright 1999-2007 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 DESCRIPTION="New generation connection pool server for PostgreSQL" | |
5 HOMEPAGE="http://pgpool.projects.postgresql.org/" | |
6 SRC_URI="http://pgfoundry.org/frs/download.php/2108/${P}.tar.gz" | |
7 | |
8 LICENSE="BSD" | |
9 SLOT="0" | |
10 KEYWORDS="~amd64 ~ppc ~sparc ~x86" | |
11 IUSE="" | |
12 | |
13 DEPEND="virtual/postgresql-base" | |
14 | |
15 src_unpack() { | |
16 unpack ${A} | |
17 S="${WORKDIR}/${PN}-2.2" | |
18 cd ${S} | |
19 sed -i -e "/^logdir/s:/tmp:/var/run:g" pgpool.conf.sample || die | |
20 } | |
21 | |
22 src_compile() { | |
23 econf || die | |
24 emake || die | |
25 } | |
26 | |
27 src_install () { | |
28 einstall || die | |
29 mv ${D}/etc/pcp.conf.sample ${D}/etc/pcp.conf | |
30 mv ${D}/etc/pgpool.conf.sample ${D}/etc/pgpool.conf | |
31 mv ${D}/etc/pool_hba.conf.sample ${D}/etc/pool_hba.conf | |
32 dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO | |
33 newinitd "${FILESDIR}/pgpool-II.init" pgpool-II || die "Inserting init.d-file failed" | |
34 } |