Mercurial > hg > portage
comparison dev-util/bouml/bouml-4.3.5.ebuild @ 32:b23455d0adfe
add bouml 4.3.5 ebuild
author | Dirk Olmes <dirk.olmes@googlemail.com> |
---|---|
date | Tue, 10 Jun 2008 17:11:23 +0200 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
31:51b6b390a7d8 | 32:b23455d0adfe |
---|---|
1 # Copyright 1999-2007 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/dev-util/bouml/bouml-3.4.ebuild,v 1.1 2007/12/23 21:27:06 ferdy Exp $ | |
4 | |
5 inherit multilib qt3 | |
6 | |
7 MY_P="${PN}_${PV}" | |
8 | |
9 DESCRIPTION="Free UML 2 tool with code generation" | |
10 HOMEPAGE="http://bouml.free.fr/" | |
11 SRC_URI="http://bouml.free.fr/${MY_P}.tar.gz" | |
12 | |
13 LICENSE="GPL-2" | |
14 SLOT="0" | |
15 KEYWORDS="~amd64 ~x86 ~x86-fbsd" | |
16 IUSE="" | |
17 | |
18 DEPEND="$(qt_min_version 3)" | |
19 RDEPEND="${DEPEND}" | |
20 | |
21 S="${WORKDIR}/${MY_P}" | |
22 | |
23 src_compile() { | |
24 find src/ genplugouts/ -type f -name "*.pro" | while read file; do | |
25 local subdir="${file%/*}" | |
26 eqmake3 "${file}" -o "${subdir}"/Makefile | |
27 emake -C "${subdir}" || die "emake failed in ${subdir}" | |
28 done | |
29 } | |
30 | |
31 src_install() { | |
32 emake BOUML_LIB="/usr/$(get_libdir)/bouml" DESTDIR="${D}" install \ | |
33 || die "emake install failed" | |
34 } |