comparison net-misc/gopenvpn/gopenvpn-9999-r1.ebuild @ 352:c417ea2d1eab

ebuild fro gopenvpn
author Dirk Olmes <dirk@xanthippe.ping.de>
date Fri, 07 Feb 2014 08:14:57 +0100
parents
children
comparison
equal deleted inserted replaced
351:8052b944a4a9 352:c417ea2d1eab
1 # Copyright 1999-2013 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 EAPI=5
6
7 # project is hosted on sourceforge's git, so git-2 is needed (git is deprecated)
8 inherit git-2 autotools
9
10 DESCRIPTION="gopenvpn is a gtk tray icon for openvpn"
11 HOMEPAGE="http://gopenvpn.sourceforge.net/"
12
13 EGIT_REPO_URI="git://gopenvpn.git.sourceforge.net/gitroot/gopenvpn/gopenvpn.git"
14 SRC_URI=""
15
16 LICENSE="GPL-2"
17 SLOT="0"
18 KEYWORDS="~x86 ~amd64"
19
20 RDEPEND="dev-libs/glib:2
21 x11-libs/gtk+:2
22 gnome-base/libglade
23 gnome-base/gnome-keyring
24 sys-auth/polkit"
25
26 src_prepare() {
27 gettextize
28 sed -i '124s/.*/AC_CONFIG_FILES([pixmaps\/Makefile/' configure.ac
29 autoreconf -vif
30 ./configure
31 }