comparison dev-db/pgpool-II/pgpool-II-2.2.3.ebuild @ 153:c494760eb51c

update pgpool-II to 2.2.3
author holger
date Fri, 14 Aug 2009 00:43:39 +0200
parents dev-db/pgpool-II/pgpool-II-2.2.2.ebuild@b2bf9b2e80c7
children
comparison
equal deleted inserted replaced
152:2cb495e793ae 153:c494760eb51c
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3
4 DESCRIPTION="New generation connection pool server for PostgreSQL"
5 HOMEPAGE="http://pgpool.projects.postgresql.org/"
6 SRC_URI="http://pgfoundry.org/frs/download.php/2108/${P}.tar.gz"
7
8 LICENSE="BSD"
9 SLOT="0"
10 KEYWORDS="~amd64 ~ppc ~sparc ~x86"
11 IUSE=""
12
13 DEPEND="virtual/postgresql-base"
14
15 src_unpack() {
16 unpack ${A}
17 S="${WORKDIR}/${PN}-2.2"
18 cd ${S}
19 sed -i -e "/^logdir/s:/tmp:/var/run:g" pgpool.conf.sample || die
20 }
21
22 src_compile() {
23 econf --with-pgsql=/usr/include/postgresql || die
24 emake || die
25 }
26
27 src_install () {
28 einstall || die
29 mv ${D}/etc/pcp.conf.sample ${D}/etc/pcp.conf
30 mv ${D}/etc/pgpool.conf.sample ${D}/etc/pgpool.conf
31 mv ${D}/etc/pool_hba.conf.sample ${D}/etc/pool_hba.conf
32 dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README* TODO
33 newinitd "${FILESDIR}/pgpool-II.init" pgpool-II || die "Inserting init.d-file failed"
34 }