comparison media-sound/exaile/exaile-0.3.1.1.ebuild @ 328:cee7e5f9f250

Automated merge with http://hoho.dyndns.org/hg/portage
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 02 Apr 2012 15:39:05 +0200
parents a588f50b1e1d
children
comparison
equal deleted inserted replaced
327:19a25aae5976 328:cee7e5f9f250
1 # Copyright 1999-2010 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: /var/cvsroot/gentoo-x86/media-sound/exaile/Attic/exaile-0.3.1.1.ebuild,v 1.2 2010/08/14 17:33:32 ssuominen dead $
4
5 EAPI=2
6
7 PYTHON_DEPEND="2:2.6"
8 PYTHON_USE_WITH="sqlite"
9
10 inherit fdo-mime multilib python
11
12 DESCRIPTION="a media player aiming to be similar to AmaroK, but for GTK+"
13 HOMEPAGE="http://www.exaile.org/"
14 SRC_URI="http://launchpad.net/exaile/0.3.1/${PV}/+download/${P}.tar.gz"
15
16 LICENSE="GPL-2 GPL-3"
17 SLOT="0"
18 KEYWORDS="~amd64 ~ppc ~sparc x86"
19 IUSE="cddb libnotify nls"
20
21 RDEPEND="dev-python/dbus-python
22 >=media-libs/mutagen-1.10
23 >=dev-python/pygtk-2.14
24 >=dev-python/pygobject-2.18
25 dev-python/gst-python:0.10
26 media-libs/gst-plugins-good:0.10
27 media-plugins/gst-plugins-meta:0.10
28 libnotify? ( dev-python/notify-python )
29 cddb? ( dev-python/cddb-py )"
30 DEPEND="nls? ( dev-util/intltool
31 sys-devel/gettext )"
32
33 # Required python 'mox' module missing wrt #315589
34 RESTRICT="test"
35
36 pkg_setup() {
37 python_set_active_version 2
38 }
39
40 src_prepare() {
41 sed -i \
42 -e "s:exec python:exec $(PYTHON):" \
43 exaile tools/generate-launcher || die
44 }
45
46 src_compile() {
47 if use nls; then
48 emake locale || die
49 fi
50 }
51
52 src_install() {
53 local _no_locale
54 use nls || _no_locale=_no_locale
55
56 emake PREFIX="/usr" LIBINSTALLDIR="/$(get_libdir)" DESTDIR="${D}" \
57 install${_no_locale} || die
58
59 dodoc README
60
61 insinto /usr/share/exaile/data
62 doins -r data/migrations || die
63 }
64
65 pkg_postinst() {
66 python_need_rebuild
67 python_mod_optimize /usr/$(get_libdir)/${PN}
68 fdo-mime_desktop_database_update
69 fdo-mime_mime_database_update
70 }
71
72 pkg_postrm() {
73 python_mod_cleanup /usr/$(get_libdir)/${PN}
74 fdo-mime_desktop_database_update
75 fdo-mime_mime_database_update
76 }