comparison sys-apps/servant/servant-0.1.7.ebuild @ 328:cee7e5f9f250

Automated merge with http://hoho.dyndns.org/hg/portage
author Dirk Olmes <dirk@xanthippe.ping.de>
date Mon, 02 Apr 2012 15:39:05 +0200
parents 5dfe37a85527
children
comparison
equal deleted inserted replaced
327:19a25aae5976 328:cee7e5f9f250
1 # Copyright 1999-2006 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 inherit eutils
6
7 DESCRIPTION="Graphical rc-update replacement (Qt4)"
8
9 # Homepage, not used by Portage directly but handy for developer reference
10 HOMEPAGE="http://www.informatik.uni-bremen.de/~momesana/sys-apps/servant/"
11 SRC_URI="http://www.informatik.uni-bremen.de/~momesana/sys-apps/servant/${P}.tar.bz2"
12 LICENSE="GPL-2"
13 SLOT="0"
14 KEYWORDS="~x86 ~amd64"
15 IUSE=""
16 DEPEND=">=x11-libs/qt-4.2.0"
17 S=${WORKDIR}/${PN}
18
19 src_compile() {
20 qmake || die "qmake failed"
21 emake || die "emake failed"
22 }
23
24 src_install() {
25 dobin ${S}/servant || die "dobin ${S}/servant failed"
26
27 dodoc ${S}/AUTHORS \
28 ${S}/COPYING \
29 ${S}/ChangeLog \
30 ${S}/README \
31 ${S}/TODO || die "installing documentation failed"
32 insinto /usr/share/applnk/System/
33 doins ${S}/servant.desktop
34 }
35
36 pkg_postinst() {
37 einfo "Send your Bugreports to momesana@yahoo.de"
38 }