Mercurial > hg > portage
comparison www-apps/radicale/radicale-2.1.8.ebuild @ 505:cf7ebc4098d5
Automated merge with https://localhost/hg/portage
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Fri, 01 Feb 2019 04:59:35 +0100 |
parents | 510b2157b669 |
children |
comparison
equal
deleted
inserted
replaced
466:152b03a42260 | 505:cf7ebc4098d5 |
---|---|
1 # Copyright 1999-2017 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 | |
4 EAPI=6 | |
5 | |
6 PYTHON_COMPAT=( python{3_4,3_5,3_6} ) | |
7 | |
8 inherit eutils distutils-r1 user | |
9 | |
10 MY_PN="Radicale" | |
11 MY_P="${MY_PN}-${PV}" | |
12 | |
13 DESCRIPTION="A simple CalDAV calendar server" | |
14 HOMEPAGE="http://www.radicale.org/" | |
15 SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz" | |
16 | |
17 LICENSE="GPL-3" | |
18 SLOT="0" | |
19 KEYWORDS="~amd64 ~x86" | |
20 IUSE="+bcrypt" | |
21 | |
22 DEPEND=" | |
23 dev-python/vobject | |
24 bcrypt? ( app-admin/apache-tools dev-python/passlib[bcrypt] )" | |
25 | |
26 S=${WORKDIR}/${MY_P} | |
27 | |
28 RDIR=/var/lib/radicale | |
29 LDIR=/var/log/radicale | |
30 | |
31 pkg_setup() { | |
32 enewgroup radicale | |
33 enewuser radicale -1 -1 ${RDIR} radicale | |
34 } | |
35 | |
36 python_install_all() { | |
37 rm README* || die | |
38 | |
39 # init file | |
40 newinitd "${FILESDIR}"/radicale.init.d radicale | |
41 | |
42 # directories | |
43 diropts -m0750 | |
44 dodir ${RDIR} | |
45 fowners radicale:radicale ${RDIR} | |
46 diropts -m0755 | |
47 dodir ${LDIR} | |
48 fowners radicale:radicale ${LDIR} | |
49 | |
50 # config file | |
51 insinto /etc/${PN} | |
52 doins config logging | |
53 | |
54 # fcgi and wsgi files | |
55 exeinto /usr/share/${PN} | |
56 doexe radicale.wsgi | |
57 doexe radicale.fcgi | |
58 | |
59 distutils-r1_python_install_all | |
60 } | |
61 | |
62 pkg_postinst() { | |
63 einfo "A sample WSGI script has been put into ${ROOT}usr/share/${PN}." | |
64 einfo "You will also find there an example FastCGI script." | |
65 } |