Mercurial > hg > portage
comparison net-im/mcabber/mcabber-0.10.3.ebuild @ 375:d130eab1967f
add mcabber build
author | Dirk Olmes <dirk@xanthippe.ping.de> |
---|---|
date | Sun, 04 Jan 2015 05:28:32 +0100 |
parents | |
children |
comparison
equal
deleted
inserted
replaced
374:3f197242b810 | 375:d130eab1967f |
---|---|
1 # Copyright 1999-2014 Gentoo Foundation | |
2 # Distributed under the terms of the GNU General Public License v2 | |
3 # $Header: /var/cvsroot/gentoo-x86/net-im/mcabber/mcabber-0.10.2_p20131025-r1.ebuild,v 1.1 2014/03/30 12:49:40 wschlich Exp $ | |
4 | |
5 EAPI=5 | |
6 | |
7 inherit flag-o-matic autotools-utils | |
8 | |
9 DESCRIPTION="A small Jabber console client with various features, like MUC, SSL, PGP" | |
10 HOMEPAGE="http://mcabber.com/" | |
11 SRC_URI="http://mcabber.com/files/mcabber-${PV}.tar.bz2" | |
12 | |
13 LICENSE="GPL-2" | |
14 SLOT="0" | |
15 KEYWORDS="~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos" | |
16 | |
17 IUSE="aspell crypt idn modules otr spell ssl vim-syntax" | |
18 | |
19 LANGS="cs de fr it nl pl ru uk" | |
20 # localized help versions are installed only, when LINGUAS var is set | |
21 for i in ${LANGS}; do | |
22 IUSE="${IUSE} linguas_${i}" | |
23 done; | |
24 | |
25 RDEPEND="crypt? ( >=app-crypt/gpgme-1.0.0 ) | |
26 otr? ( >=net-libs/libotr-3.1.0 ) | |
27 aspell? ( app-text/aspell ) | |
28 vim-syntax? ( || ( app-editors/vim app-editors/gvim ) ) | |
29 idn? ( net-dns/libidn ) | |
30 spell? ( app-text/enchant ) | |
31 dev-libs/glib:2 | |
32 sys-libs/ncurses | |
33 >=net-libs/loudmouth-1.4.3-r1[ssl?]" | |
34 DEPEND="${RDEPEND} | |
35 virtual/pkgconfig" | |
36 | |
37 ## autotools-utils.eclass settings | |
38 AUTOTOOLS_AUTORECONF="1" | |
39 AUTOTOOLS_IN_SOURCE_BUILD="1" | |
40 DOCS=( AUTHORS ChangeLog NEWS README TODO mcabberrc.example doc/README_PGP.txt ) | |
41 #PATCHES=( | |
42 # "${FILESDIR}/${P}-vim-ftdetect.patch" | |
43 #) | |
44 | |
45 pkg_setup() { | |
46 if use aspell && use spell; then | |
47 ewarn "NOTE: You have both USE flags 'aspell' and 'spell' enabled, enchant (USE flag 'spell') will be preferred." | |
48 fi | |
49 } | |
50 | |
51 src_configure() { | |
52 local myeconfargs=( | |
53 $(use_enable crypt gpgme) \ | |
54 $(use_enable otr) \ | |
55 $(use_enable aspell) \ | |
56 $(use_enable spell enchant) \ | |
57 $(use_enable modules) \ | |
58 $(use_with idn libidn) | |
59 ) | |
60 autotools-utils_src_configure | |
61 } | |
62 | |
63 src_install() { | |
64 autotools-utils_src_install | |
65 | |
66 # clean unneeded language documentation | |
67 for i in ${LANGS}; do | |
68 use linguas_${i} || rm -rf "${ED}"/usr/share/${PN}/help/${i} | |
69 done | |
70 | |
71 # contrib themes | |
72 insinto /usr/share/${PN}/themes | |
73 doins "${S}"/contrib/themes/* | |
74 | |
75 # contrib generic scripts | |
76 exeinto /usr/share/${PN}/scripts | |
77 doexe "${S}"/contrib/*.{pl,py} | |
78 | |
79 # contrib event scripts | |
80 exeinto /usr/share/${PN}/scripts/events | |
81 doexe "${S}"/contrib/events/* | |
82 | |
83 if use vim-syntax; then | |
84 cd contrib/vim/ || die | |
85 | |
86 insinto /usr/share/vim/vimfiles/syntax | |
87 doins mcabber_log-syntax.vim | |
88 | |
89 insinto /usr/share/vim/vimfiles/ftdetect | |
90 doins mcabber_log-ftdetect.vim | |
91 fi | |
92 } | |
93 | |
94 pkg_postinst() { | |
95 elog | |
96 elog "MCabber requires you to create a subdirectory .mcabber in your home" | |
97 elog "directory and to place a configuration file there." | |
98 elog "An example mcabberrc was installed as part of the documentation." | |
99 elog "To create a new mcabberrc based on the example mcabberrc, execute the" | |
100 elog "following commands:" | |
101 elog | |
102 elog " mkdir -p ~/.mcabber" | |
103 elog " bzcat ${EROOT}usr/share/doc/${PF}/mcabberrc.example.bz2 >~/.mcabber/mcabberrc" | |
104 elog | |
105 elog "Then edit ~/.mcabber/mcabberrc with your favorite editor." | |
106 elog | |
107 elog "See the CONFIGURATION FILE and FILES sections of the mcabber" | |
108 elog "manual page (section 1) for more information." | |
109 elog | |
110 elog "From version 0.9.0 on, MCabber supports PGP encryption of messages." | |
111 elog "See README_PGP.txt for details." | |
112 echo | |
113 einfo "Check out ${EROOT}usr/share/${PN} for contributed themes and event scripts." | |
114 echo | |
115 } |